Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How do I make Postfix reject all mails when the client is not authenticated and the sender is from my domain? Is there an easy way to do this?

share|improve this question

migrated from superuser.com Aug 4 '12 at 12:20

This question came from our site for computer enthusiasts and power users.

> How do I stop my machine from receiving any mail from the world at large? No, that would be if I would refuse not authenticated mail delivery with @mydomain as recipient. –  Max Ried Jun 3 '11 at 15:12
Can you clarify a bit more what you're looking to block? Unauthenticated users sending mail to the world at large using your server? Users sending mail with your domain as the "from" address? –  blahdiblah Jun 6 '11 at 23:28
If the MAIL FROM's domain is my domain AND the client that tries to deliver it to MY server it should reject it. Of course it only should reject the mails if the client is NOT authenticated. It's just that my server should be aware of that there is no one else than me who should be able to send mails from @mydomain –  Max Ried Jun 7 '11 at 8:19

1 Answer 1

It seems the reject_unauthenticated_sender_login_mismatch option for the smtpd_sender_restrictions configuration could help you out. It probably needs a bit of configuration depending on your actual setup.

You might want to check the ADDRESS VERIFICATION README and the part about forged sender for more details. It actually says it's good to turn it on for your own domains, but only on small servers (this might not be suitable on an ISP scale server farm).

This, indeed, could be more useful on ServerFault.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.