Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have a Server in our office with an Adaptec 2820SA RAID contoller in it, and since the day we got it its been purely excellent.

However, we recently wanted to increase the size of our storage options and have bought 4 x brand new 1.5TB drives for a new RAID5 array. But when I went into the controller to configure it, The drives were not "available" to create an array.

It seems like the controller, despite having 8 SATA channels, is only capable of 1 array at a time.

I have tried googling this theory with no result. Is anyone able to confirm this for me?

share|improve this question

Are you on the latest firmware/drivers? those 1.5TB disks are quite new and may not be supported by the version of firmware you currently have, or ever for that matter.

share|improve this answer
up vote 2 down vote accepted

I found the cause. After some more digging I found this on the Adaptec Support page for the 2820SA. As follows:

Capacity: Max. physical disk drive size: 1TB

So obviously a flash of the BIOS isn't going to do me much good anyway (even if the floppy drive in the server WAS working. Thanks for the suggestions though guys.

share|improve this answer
You beat me to it - I was about to post this exact answer. – Mark Henderson Jul 17 '09 at 0:36

Something similar happened to me before:

Did you set up a RAID on the 4 new drives before? Often, the drives are then marked as "in use" and not available for a new raid until you free them.

share|improve this answer

If the 1.5TB drives are seagate barracuda, they're desktop drives and they're very well known for having all sort of problems. They behave extremely poorly in RAID configuration, notwithstanding the fact that as desktop drives, they're not supposed to be used this way.

share|improve this answer
I think they are Barracudas, but that being said the previous Array of 4 x 300GB Drives were also barracudas, and worked amazingly well. They just arn't big enough anymore. – Ash Jul 16 '09 at 21:59
Most barracudas are OK, BUT the 1.5TB model. – wazoox Jul 17 '09 at 10:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.