Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I need to run a client's software locally on my machine and have it talk over a VPN link (Team Viewer VPN) to connect to the live database so I can attach a debugger to the client software and figure some issues out that the client is having.

When any of the computers on the client's network connect it works fine. Here is the output from the driver's debug information.

Sun Aug 05 2012 15:06:10
15:06:10 CONN: Application information:
15:06:10 "HOST=WORKSTATION36;OS=Windows XP Build 2600 Service Pack 3;PID=0x11a0;THREAD=0xdcc;EXE=C:\abba\dbisqlc.exe;VERSION=7.0.4.3472;API=DBLIB"
15:06:10 CONN: Attempting to connect using:
UID=abdbo;PWD=*****;DBN=abba;ENG=abba;ASTOP=YES;DBG=YES;LOG=C:\log\odbcLog.txt;DMRF=NO;LINKS=TCPIP{}
15:06:10 Trying to start TCPIP link ...

15:06:10 Loading wsock32.dll
15:06:10 Loading ws2_32.dll
15:06:10 TCP using Winsock version 2.0
15:06:10 My IP address is 192.168.0.111
15:06:10 My IP address is 127.0.0.1
15:06:10     TCPIP link started successfully

15:06:10 Trying 192.168.0.2:2638
15:06:10 Found database server abba on TCPIP link
15:06:10 Client connected
15:06:10 CONN: Connected to the server
15:06:10 [1174510859] CONN: Connected to database successfully
15:06:10 [1174510859] Client disconnected

However if I attempt to connect using my VPN link it does not work.

Sun Aug 05 2012 17:13:26
17:13:26 CONN: Application information:
17:13:26 "HOST=CONVERSIONVM;OS=Windows 2003 Build 3790 Service Pack 2;PID=0x878;THREAD=0x98c;EXE=C:\abba\dbisqlc.exe;VERSION=7.0.4.3472;API=DBLIB"
17:13:26 CONN: Attempting to connect using:
UID=abdbo;PWD=*****;DBN=abba;ENG=abba;ASTOP=YES;DBG=YES;LOG=C:\log\odbcLog.txt;DMRF=NO;LINKS=TCPIP{}
17:13:26 Trying to start TCPIP link ...
17:13:26 Loading wsock32.dll
17:13:26 Loading ws2_32.dll
17:13:26 TCP using Winsock version 2.0
17:13:26 My IP address is 7.192.193.89
17:13:26 My IP address is 10.0.1.106
17:13:26 My IP address is 127.0.0.1
17:13:26     TCPIP link started successfully
17:13:26 Looking for abba
17:13:26 I am in a class A network
17:13:26 Sending broadcast
17:13:26 Using broadcast address of: 7.255.255.255:2638
17:13:26 I am in a class A network
17:13:26 Sending broadcast
17:13:26 Using broadcast address of: 10.255.255.255:2638
17:13:26 I am in a class A network
17:13:26 Sending broadcast
17:13:26 Using broadcast address of: 127.255.255.255:2638
17:13:27     No reply received
17:13:27 Resending
17:13:28     No reply received
17:13:28 Resending
17:13:29     No reply received
17:13:29 Resending
17:13:30     No reply received
17:13:30 Resending
17:13:31     No reply received
17:13:31 CONN: Cannot connect

A few issues I think could be the problem is the fact that Team Viewer wants me to route the traffic through it's special IP and the broadcast is not transmitted through it. I attempted to tell the TCP/IP link to use the server's VPN's IP and port but that did not solve the issue either

Sun Aug 05 2012 17:29:29
17:29:29 CONN: Application information:
17:29:29 "HOST=CONVERSIONVM;OS=Windows 2003 Build 3790 Service Pack 2;PID=0x13c;THREAD=0x810;EXE=C:\abba\dbisqlc.exe;VERSION=7.0.4.3472;API=DBLIB"
17:29:29 CONN: Attempting to connect using:
UID=abdbo;PWD=*****;DBN=abba;ENG=abba;ASTOP=YES;DBG=YES;LOG=C:\log\odbcLog.txt;DMRF=NO;LINKS=TCPIP{IP=7.192.141.131;PORT=2638}
17:29:29 Trying to start TCPIP link ...
17:29:29 Loading wsock32.dll
17:29:29 Loading ws2_32.dll
17:29:29 TCP using Winsock version 2.0
17:29:29 My IP address is 7.192.193.89
17:29:29 My IP address is 10.0.1.106
17:29:29 My IP address is 127.0.0.1
17:29:29     TCPIP link started successfully
17:29:29 Looking for abba
17:29:29 I am in a class A network
17:29:29 Sending broadcast
17:29:29 Using broadcast address of: 7.255.255.255:2638
17:29:29 I am in a class A network
17:29:29 Sending broadcast
17:29:29 Using broadcast address of: 10.255.255.255:2638
17:29:29 I am in a class A network
17:29:29 Sending broadcast
17:29:29 Using broadcast address of: 127.255.255.255:2638
17:29:29 Trying 7.192.141.131
17:29:29 Trying 7.192.141.131
17:29:30     No reply received
17:29:30 Resending
17:29:31     No reply received
17:29:31 Resending
17:29:32     No reply received
17:29:32 Resending
17:29:33     No reply received
17:29:33 Resending
17:29:34     No reply received
17:29:34 CONN: Cannot connect

One thing I did notice is that the port was not listed on the Trying 7.192.141.131 even though I explicitly told it to use that port and the same line in the working log shows the port included as Trying 192.168.0.2:2638.

Firewalls are disabled on both the client and server so the problem is not related to that, I think it is because the port number is not being set but I do not know what I am doing wrong to cause it not to be set.

This is using the Adaptive Server Anywhere 7.0 driver.

share|improve this question

migrated from dba.stackexchange.com Aug 6 '12 at 9:33

This question came from our site for database professionals who wish to improve their database skills and learn from others in the community.

    
There's nothing we can do to help. Talk to your clients helpdesk or network people. Apologies, but we're not an IT helpdesk :) –  FreshPhilOfSO Aug 6 '12 at 0:14
    
Agreeing with @Phil, this is far more likely to be a VPN configuration/network setup issue than a database issue. –  Simon Righarts Aug 6 '12 at 0:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.