Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm in the process of making and answers file for Windows 7. Mostly it's done however, I can't work out how to Add the autologon to the answers file. See below.

No matter where I put the Autologon in the section, when using the file it always stops at the first prompt of Language, currency etc on the install.

Anyone any ideas what I'm doing wrong?

<?xml version="1.0" encoding="utf-8"?>
<!--This answer file generated by RT Seven Lite-->
<unattend xmlns="urn:schemas-microsoft-com:unattend">
  <settings pass="windowsPE">
    <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <SetupUILanguage>
        <UILanguage>en-US</UILanguage>
      </SetupUILanguage>
      <InputLocale>0409:00000409</InputLocale>
      <UserLocale>en-GB</UserLocale>
      <UILanguage>en-US</UILanguage>
      <SystemLocale>en-US</SystemLocale>
    </component>
    <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
        <DiskConfiguration>
            <Disk wcm:action="add">
                <DiskID>0</DiskID>
                <WillWipeDisk>true</WillWipeDisk>
                <CreatePartitions>

                     <!-- System partition -->
                     <CreatePartition wcm:action="add">
                        <Order>1</Order>
                        <Type>Primary</Type>
                        <Size>102400</Size>
                    </CreatePartition>

                    <!-- Windows partition -->
                    <CreatePartition wcm:action="add">
                        <Order>2</Order>
                        <Type>Primary</Type>
                        <Extend>true</Extend>
                    </CreatePartition>
                </CreatePartitions>
                <ModifyPartitions>

                    <!-- System partition -->
                    <ModifyPartition wcm:action="add">
                        <Order>1</Order>
                        <PartitionID>1</PartitionID>
                        <Label>Windwow</Label>
                        <Letter>C</Letter>
                        <Format>NTFS</Format>
                        <Active>true</Active>
                    </ModifyPartition>

                    <!-- Windows partition -->
                    <ModifyPartition wcm:action="add">
                        <Order>2</Order>
                        <PartitionID>2</PartitionID>
                        <Label>Data</Label>
                        <Letter>D</Letter>
                        <Format>NTFS</Format>
                    </ModifyPartition>
                </ModifyPartitions>
            </Disk>
            <WillShowUI>OnError</WillShowUI>
        </DiskConfiguration>
      <ImageInstall>
        <OSImage>
          <InstallFrom>
            <MetaData wcm:action="add">
              <Key>/IMAGE/NAME</Key>
              <value>Windows 7 ENTERPRISE</value>
            </MetaData>
          </InstallFrom>
           <InstallTo>
            <DiskID>0</DiskID>
            <PartitionID>1</PartitionID>
          </InstallTo>
          <InstallToAvailablePartition>false</InstallToAvailablePartition>
          <WillShowUI>OnError</WillShowUI>
        </OSImage>
      </ImageInstall>
      <UserData>
        <ProductKey>
          <Key>somekey</Key>
          <WillShowUI>OnError</WillShowUI>
        </ProductKey>
        <Organization>fast_comp</Organization>
        <FullName>dumbo</FullName>
        <AcceptEula>true</AcceptEula>
      </UserData>
    </component>
  </settings>
  <settings pass="oobeSystem">
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
        <UserAccounts>
            <LocalAccounts>
                <LocalAccount wcm:action="add">
                    <Name>dumbo</Name>
                    <Group>Administrators</Group>
                    <Password>
                        <PlainText>true</PlainText>
                        <Value>passwd</Value>
                    </Password>
                </LocalAccount>
            </LocalAccounts>
        </UserAccounts>
        <OOBE>
            <NetworkLocation>Work</NetworkLocation>
            <HideEULAPage>true</HideEULAPage>
            <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
            <SkipMachineOOBE>true</SkipMachineOOBE>
            <SkipUserOOBE>true</SkipUserOOBE>
        </OOBE>
        <DisableAutoDaylightTimeSet>false</DisableAutoDaylightTimeSet>
        <TimeZone>GMT Standard Time</TimeZone>
        <AutoLogon>
            <Password>
                <Value>passwd</Value>
                <PlainText>true</PlainText>
            </Password>
            <Domain>.</Domain>
            <Enabled>true</Enabled>
            <LogonCount>1</LogonCount>
            <Username>dumbo</Username>
           </AutoLogon>
    </component>
  </settings>
  <settings pass="specialize">
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <ComputerName>RENAME_ME</ComputerName>
    </component>
    <component name="Microsoft-Windows-Security-Licensing-SLC-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <SkipAutoActivation>true</SkipAutoActivation>
    </component>
  </settings>
</unattend>
share|improve this question

2 Answers 2

That doesn't have anything to do with the autologin necessarily. It just means that you haven't filled in the proper locale information necessary to skip those steps.

share|improve this answer
    
Interestingly, if I remove the AutoLogon section it works fine. I wonder if there is a typo somewhere (specifically in the autologon section) and the answers file is being rejected. –  Satpal Aug 6 '12 at 12:27

According to this article, putting the InputLocale information in the oobesystem pass will skip the regional settings page of Windows Welcome.

Are you using Windows SIM to create and validate your unattend file? When I put your file into WSIM, it came back with 3 deprecated settings being used:

SkipMachineOOBE

SkipUserOOBE

SkipAutoActivation

The Windows System Image Manager is a part of the Windows Automated Installation Kit (WAIK) and will help you create your unattend file, and will validate the file for you so you can see any errors. You can find more help on building your desktop image on the Deliver and Deploy page of the Springboard Series on TechNet.

One final comment, The Microsoft Deployment Toolkit (MDT) ties many of Microsoft’s free deployment tools together into one common console, and can make capturing and deploying Windows much easier.

David from the Windows Outreach Team

share|improve this answer
    
I'm using a third party tool (rt7lite) to create the file. However whenever I load the file in SIM, validate is greyed out and there is a warning in the Messages->XML saying: "Cannot find Windows image information in answer file". I will have a look at the deliver and deploy page you mention and at MDT. Thanks –  Satpal Aug 7 '12 at 11:41
    
Yes, you will have to associate the answer file to an image. See this article for help. –  WinOutreach4 Aug 7 '12 at 15:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.