Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Symantec Backup Exec 12.5 on Microsoft Windows Server 2003 Standard x64 SP2 on 1 server for backups. I am running Microsoft Exchange 2007 Standard on another 2003 Server. I use Backup Exec to back up my Exchange database. When Backup Exec was performing a backup about a month ago it had an error and the process failed. Backup Exec left a locked page file in the volume with my database on my SAN. This page file is taking up the space I need for the new page file for my backups so I am unable to run further backups until I delete the old page file. I am unable to delete the page file because I do not have permission to even though I have administrative rights on my domain. Is there a way to unlock and delete file. I have tried Unlocker 1.8.7 with no luck. I have shut down the backup server and tried to delete the file that way and still have had no luck. Any ideas?

share|improve this question
    
Do they have a specific prefix in the file name or extension? If I knew which sort of temp file you were having trouble with I might be of more help. –  Laura Thomas Jul 28 '09 at 20:27

1 Answer 1

Sometimes those files won't go away even with all the privleges in the world because they believe they are still in use.

First try deleting the file with the Backup Exec service stopped. If that doesn't work options get more drastic.

Rebooting the server should allow the file to become deletable. I know finding a window for rebooting a production exchange box is tricky. Then again how long do people want to run without backups?

I have also freed them up with Process Explorer by looking for the process that has the file handle open and killing it. But then you're killing running processes on a production server which is of course risky.

If it's actually a VSS file you can clear them using this: http://seer.entsupport.symantec.com/docs/284154.htm

share|improve this answer
1  
In the same vein, I experienced a recurring issue with VSP scratch files and NetBackup on a Windows client. Rebooting the client allowed deletion (not optimal for a production server) but just shutting down the NetBackup services did not. Investigating with Process Explorer revealed that the virus scanner had them locked and wouldn't let go so shutting down NetBackup services and all virus scanning processes freed the files for deletion. This was a better alternative than rebooting for us until we were able to work around the problem permanently. –  damorg Aug 11 '09 at 22:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.