Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We run a web application as a production. Some days ago I discovered the error signed in subject of this theme. I know what's the problem, but want to ask, what is right way for resolve this? Yes, we have ext3 FS on this server (CentOS 5.8).

find /var/www/html1 -type f | wc -l
36039

I think that converting ext3 -> ext4 will fix this situation temporary. Ext4 has this limit twice larger than ext3 ( http://en.wikipedia.org/wiki/Ext4#Features ).

So, what is the best way?

share|improve this question

2 Answers 2

There is no setting to modify this limit, the best way would be to create another folder ( /var/www/html2 ) and create symlinks between html1/sub1/ and html2/sub1/ ect...

share|improve this answer
    
Okay. What about ext4? Is there any way to modify its limit? Maybe different FS index or another. –  Evgeniy Yablokov Aug 6 '12 at 20:04
    
There is a default limit of 64k without dir_nlink feature. When you create your FS make sure that dir_nlink is enable with mkfs.ext4. –  Arg Aug 7 '12 at 13:33
up vote 0 down vote accepted

Finally, I converted that partition to ext4.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.