Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have this init.d script

#!/bin/sh
### BEGIN INIT INFO
# Provides:          jboss
# Required-Start:    $local_fs $remote_fs $network $syslog
# Required-Stop:     $local_fs $remote_fs $network $syslog
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: Start/Stop JBoss AS v7.0.0
### END INIT INFO
#
#source some script files in order to set and export environmental variables
#as well as add the appropriate executables to $PATH
[ -r /etc/profile.d/java.sh ] && . /etc/profile.d/java.sh
[ -r /etc/profile.d/jboss.sh ] && . /etc/profile.d/jboss.sh

case "$1" in
    start)
        echo "Starting JBoss AS 7.0.0"
        #original:
        #sudo -u jboss sh ${JBOSS_HOME}/bin/standalone.sh

        #updated:
        start-stop-daemon --start --quiet --background --chuid charlie --exec $JBOSS_HOME/bin/standalone.sh
    ;;
    stop)
        echo "Stopping JBoss AS 7.0.0"
        #original:
        #sudo -u jboss sh ${JBOSS_HOME}/bin/jboss-admin.sh --connect command=:shutdown

        #updated:
        start-stop-daemon --start --quiet --background --chuid charlie --exec $JBOSS_HOME/bin/jboss-cli.sh -- --connect command=:shutdown
    ;;
    restart)
    ${0} stop
    ${0} start
    ;;
    *)
        echo "Usage: /etc/init.d/jboss {start|stop|restart}"
        exit 1
    ;;
esac

exit 0

I have tried sudo update-rc.d jboss.sh defaults

But it does not load! Where am i going wrong here? I am running ubuntu 10.10

share|improve this question
    
Have you tried it with --chuid jboss already? (instead of charlie) –  ott-- Aug 6 '12 at 20:50
    
What do you mean 'does not load'? –  quanta Aug 7 '12 at 7:52
    
When the machine has finished booting the script has not run what it should have run –  Charlie Davies Aug 7 '12 at 16:17

1 Answer 1

You may have the file located in the /etc/init.d directory correctly, but you need to do another step: Run the update-rc.d to enable the init file to run in the various run levels.

share|improve this answer
    
I have done this and it still fails to load on boot? –  Charlie Davies Aug 7 '12 at 16:16
    
Are the file perms 755? –  mdpc Aug 7 '12 at 17:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.