Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This log reader agent worked perfectly for several months until the user referenced in the error was removed from the domain. After that time the error 'The process could not execute 'sp_replcmds' on 'SERVER'' was received with more detail 'Could not obtain information about Windows NT group/user' that referenced said user.

This user was referenced nowhere in the the log reader agent other than the Publication Access List from which it was subsequenctly removed. The agent would still not successfully start up.

The simple problem here, I believe, is that the log reader agent was created under that user and that no longer exists in the domain. Is there an 'owner' somewhere that needs to be changed?

Every other function on the database continues to execute successfully. Any other help or thought would be appreciated.

share|improve this question
add comment

2 Answers 2

You probably just need to change the owner of the SQL Agent job which runs the replication agent. Open the replication Monitor. Select the publication in question. Select the agents tab. Double click on the Log Reader. In the new window, select the Action drop down menu then select Job Properties. Change the owner on that screen to another user, or SA. Click ok then stop and restart the agent.

share|improve this answer
    
Thanks for the reply. I have run into that with actual jobs also and have changed many to sa, but this is running continuous so that is not a job. Have looked through everything in publication properties and don't see anything. –  user49352 Aug 6 '12 at 20:45
    
It actually is a job. All the SQL Server Replication agents are, are SQL Agent jobs which call .DLL libraries which within those libraries simply run command line applications. In this case you are running the log reader, so it's running logread.exe in the background all being called from a SQL Agent job. –  mrdenny Aug 6 '12 at 20:47
    
thanks for the info. what does it call it? this sounds lame. there are exactly 9 jobs in the instance which i have looked through about a dozen times. none of them are kicked off by that user. do you know what name that job is given? –  user49352 Aug 6 '12 at 21:04
    
The log reader job will be named {Publisher}-{DatabaseName}-{SomeNumber}. The job will be on the distributor, not on the publisher. –  mrdenny Aug 6 '12 at 21:45
    
ok, found it. thanks. it says that the owner is distributor_admin. It is being used in a number of places. I am assuming that it is an alias for the domain account that is causing the error. How and where is this being set? –  user49352 Aug 7 '12 at 12:16
show 3 more comments

The database in question was owned by the AD account that was dropped from the domain. I missed the forest for the the trees.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.