My company's web server has recently failed our quarterly PCI scan on the basis of the Apache HTTPOnly Cookie Disclosure, a vulnerability only fixed from apache 2.2.22 onwards. I'm currently running Ubuntu 10.04 LTS with apache 2.2.14 and have searched high and low to find a repository for apache 2.2.22 compatible with 10.04LTS so that I may upgrade it with apt-get.
Does one exist?? Or do I need to manually update apache? Or do I need to upgrade to 12.04LTS in order to install apache 2.2.22?
Thanks a lot and I hope this helps some others out there, as I would imagine many other Techies have failed their quarterly PCI scans on the same basis!!