Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Searched Serverfault (and Google) for this, haven't been able to find an answer... We copied a VM (folder and files) from an ESXi 5.0 server (5.0.0-623860) to an ESXi 4.0 server (4.0.0-261974). (Also, the 5.0 server is licensed, and the 4.0 server is the free version.) Now when we try to start the VM on the 4.0 server, we are getting a popup error "Invalid virtual machine configuration."

Looking at the 4.0 server's logs, it is complaining of "Invalid value '/dev/char/serial/uart0' for configuration key serial0.FileName'. Value was not accepted by rule 'Virtual Serial Port Device backend'." (and the same mssg for uart1 for key serial1.FileName as well.)

Is this a simple version incompatablity between ESXi 5 to 4, which can be fixed by a conversion tool or file edit, or is this something more fundemental?

Thanks for any assistance; I'm not a VMware expert by any stretch of the imagination (more of a network guy...)

share|improve this question
1  
Well, what Virtual Machine version is the VM in question? Version 7 (IIRC) is not compatible with ESX 4. –  HopelessN00b Aug 7 '12 at 15:42
add comment

7 Answers

up vote 7 down vote accepted

It sounds like you've created the VM using machine model 8 which isn't supported on v4 (only up to 7), try exporting it to an .OVA and then reimporting it. Alternatively you could shutdown the mm8 VM, create a new mm7 VM and link the original .vmdk/s to it and try that as the differences are usually only in the .vmx file. Be aware though that mm7 VMs have more capabilities than mm4 ones so you may lose functionality that way.

share|improve this answer
add comment

You need to use the vmware converter tool. http://www.vmware.com/products/converter/

share|improve this answer
    
Thanks! You guys rawk :) –  Will Dennis Aug 7 '12 at 15:59
add comment

The references to hardware versions are incorrect guys. Version 7 of vm hardware was new on ESX(i) 4.0, and version 8 is new on ESXi 5.0. What's new on ver 4.0

Either way, obviously you've got a virtual hardware difference. Chopper3's advise about attaching the existing vmdk files to a new vm is sound advise. But, before you even do that, ask yourself if you need that serial device. Usually, they are not needed by a vm. Since you state that it was a P2V converted vm, that is just a little gift of that process. Delete the serial device from the vm config, and try to power on the vm again. Even if you got it working some other way, chances are you'd get screwed by that serial device during vmotion. Really, the P2V tool should be updated to prompt you, "do you really want a virtual serial device?????" before it virtualizes it. They're generally useless.

share|improve this answer
add comment

There are different versions of ESXi hardware. The most common are v4 (which is the highest version supported on ESX 3.x), v7 (ESX(i) 4.x) and v8 (ESXi 5). ESXi 5 can make VMs with either, but make v8 VMs by default. These cannot be run on ESXi 4.

Unless you explicitly created the VM on ESXi 5 as a v7 VM, you're out of luck.

share|improve this answer
    
Not entirely out of luck, they can be converted. –  Zoredache Aug 7 '12 at 15:33
    
True. I meant out of luck as far as "copy and run" goes. –  MDMarra Aug 7 '12 at 15:34
    
It was a P2V of a "real" server... Do you know offhand if the 5.0 P2V tool has the facility to create the VM as a v4 VM? –  Will Dennis Aug 7 '12 at 15:34
1  
You can always do the P2V with the v4 VC as the target. –  Chopper3 Aug 7 '12 at 15:34
    
@Zoredache - link for how to convert? –  Will Dennis Aug 7 '12 at 15:35
add comment

VM Converter 5.0.1 build-875114 on Winodws is working GREAT to migrate my VMs from esxi5 -> exsi4. esxi4 was needed to see my 64GB RAM on my new server.

share|improve this answer
add comment

Howto Convert a ESXv5 to ESXv4 VM

This details the steps needed to convert a machine from ESXv5 to ESXv4

Convert OVA to VMX

  1. On ESXv5 Machine, Export the VMWare ESX5 Machine to OVF (File -> Export -> Export OVF Template)
  2. Download ovftool
  3. Convert ova to vmx (ignoring manifest errors)

    ovftool sourefile.ova destfile.vmx (make sure filename [without extension] is different)
    
  4. Modify the vmx file

Change

virtualhw.version = "8"

to:

virtualhw.version = "7"

Convert back to OVF

(this takes awhile because 9 is max compression)

ovftool --compress=9 destfile.vm destfile_converted.ovf

Deploy OVF on your ESXv4 Machine

Import OVF like normal on your ESXv4 machine

source: http://brakertech.com/howto-convert-a-esxv5-to-esxv4-vm/

share|improve this answer
add comment

Same problem here. Had to move a not so important VM to an ESXi4.1 to expand the RAM.

I just managed to copy the ESXi5.1 files for a specfiec VM to ESXi4.1. I compared the .vmx's for both versions and made the ESXi5.1 version to look exactly like the ESXi4.1 one, but have not changed the item's values (except for the "virtualHW.version", which I changed from "8" to "7").

The VM starts normally.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.