Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have downloaded Ioncube then using unzip tar and placed it in document root. Then changed the php.ini file.. I did all according to:

http://www.howtoforge.com/installation-of-zendoptimizer-and-ioncubeloader-using-lighttpd-on-centos

Then I restart my httpd & got this error: (my httpd was not re-starting initially i was getting error:

Starting httpd: (98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80

then i used sudo fuser -k -n tcp 80 then i was able to restart..)

After this i checked php -v and got:

php -v
Failed loading /usr/local/lib/ioncube/ioncube_loader_lin_5.0.so:  /usr/local/lib/ioncube/ioncube_loader_lin_5.0.so: wrong ELF class: ELFCLASS32

NOTE: php 5.3 is installed correctly using centOS 6.3 machine..

share|improve this question
    
Please post result of uname -a, you are on x86_64 architecture I guess –  Alex Aug 8 '12 at 10:25

1 Answer 1

up vote 0 down vote accepted

This error message means that you are trying to use a 32-bit library in a 64-bit environment. You should download and install the 64-bit version of ZendOptimizer and Ioncube.

share|improve this answer
    
i updated the version fro 64 bit and now i'm getting error: "[root@support ioncube]# php -v Failed loading /usr/local/lib/ioncube/ioncube_loader_lin_5.0.so: /usr/local/lib/ioncube/ioncube_loader_lin_5.0.so: undefined symbol: empty_string " –  user131274 Aug 8 '12 at 11:03
    
Oh i think im using the wrong ioncube.. sorry.. i get it know –  user131274 Aug 8 '12 at 11:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.