Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Basic working system details:

I used the Ubuntu 12.04 server CD to install a server.

I have 2 disks. I made a raid 1 array just like in ubuntu server guide : https://help.ubuntu.com/12.04/serverguide/advanced-installation.html

So I have 2 MD devices - one for swap - 4 GB, one for / - remaining 496 GB.

Everything worked just fine for last 2 months.

But now I get message:

error: Unsupported RAID level: -1000000

No such disk

Grub rescue

I tried to use rescue mode from server CD, used graphical interface to assemble raid array (partitions seem to be fine).

I tried mdadm -D /dev/md0 and mdadm -D /dev/md1 And got "md device does not appear to be active".

Any advice what to do next?

Update: I tried to follow http://superuser.com/questions/117824/how-to-get-an-inactive-raid-device-working-again But I can't use a resolution in that post, because I assembled raid array with a help of repair CD and even after that raid array is inactive and I need to boot up in the first place to add output of mdadm --examine --scan to /etc/mdadm/mdadm.conf (which is the resolution in that post)

Update2: I managed to assemble and now able to choose Ubuntu recovery mode, but during boot I get this message:

Failed to spawn friendly-recovery post-stop process: unable to execute: No such file or directory

Update3: We found some data loss and stuck again :) Then decided to ask question here, now about data loss: http://askubuntu.com/questions/174172/data-hidden-or-lost-on-hdds-in-raid1-on-ubuntu-server-12-04#174172

share|improve this question
    
Try to follow the instructions from this other post: superuser.com/questions/117824/… –  Kao Aug 8 '12 at 12:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.