Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Yesterday, I created a new instance but I cannot connect to it. Tried pinging it from my computer, online ping sites etc but it is just not reachable.

In the AWS console. everything seems to be functioning normally. The reachability check is successful. Screenshots are given below :

AWS Console screenshot

enter image description here

I tried using different AMIs, regions but to no avail. I just cannot connect to any AWS instance.

Please help. I'm clueless right now.

enter image description here

share|improve this question
    
Have you adjusted the Security Group for that instance to allow connections from your location? I don't recall if ICMP (e.g., ping) is allowed by default. –  cjc Aug 8 '12 at 12:55
    
The reason i tried ping is because the host was not reachable via ssh. I have another instance in another account and its 'pingable'. How do i adjust the security group to allow connections ? –  WarDoGG Aug 8 '12 at 12:57
    
There's a Security Group in the navigation plane of the control panel. Create a new one or change the default. When you start up an instance, you will be asked what Security Groups apply to that instance. –  cjc Aug 8 '12 at 12:59
    
added screenshot for the security group incoming settings. looks okay to me ? –  WarDoGG Aug 8 '12 at 12:59
add comment

1 Answer 1

up vote 5 down vote accepted

Did you allow ICMP and other traffic in security group settings? You should check the security group settings. It looks like you are using a default security group as seen on the 2nd row of 2nd column of the table on your screenshot. You should click "view rules" and adjust the rules there.

share|improve this answer
    
added screenshot for the security group incoming settings –  WarDoGG Aug 8 '12 at 13:01
    
Well you seem to be dropping all incoming connections –  Alex Aug 8 '12 at 13:02
    
i'm sorry i dont understand. Are the security settings wrong ? –  WarDoGG Aug 8 '12 at 13:04
    
the security settings blocked all the ports ! I thought it was the other way round ! Thanks ! Accepted answer for you. –  WarDoGG Aug 8 '12 at 13:09
    
Not exactly wrong but just too restrictive, you only allow incoming connections from sg-.... which I guess is related to your Amazon infrastructure but not the public web. You should a set of rules to allow hosts from 0.0.0.0/0 to access certain TCP ports or to ping the hosts in this security group. –  Alex Aug 8 '12 at 13:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.