Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've bought an domain name on Name.com, and I'm trying to setup an Website on my own server. I got apache2 running and if I go to my home address (192.168.1.19) it works, but now I am trying to link it to the adress: www.OreadGames.com and I can't really figure out how to do that.

I think it doesn't work because Name.com has a default nameserver ns1.name.com, but I can't change that one to ns1.oreadgames.com

I thought I should do it with BIND so I followed some tutorials but it still doesn't work. When I use nslookup OreadGames.com in BIND I get the following result, how do I fix this?

By the way I am using Ubuntu Server 12.10 with BIND 9 and Apache 2.2!

Server: 62.179.167.112
Address: 62.179.167.112

Non-Authoritative answer:
Name: OreadGames.com
Address: 208.43.167.112

I have editted on Name.com the DNS Record to this:

Record Type: A Record Host: ns1.oreadgames.com Record Answer: 62.163.7.106 TTL: 300

Then I've forwarded port 80 to 192.168.1.19, but it still doesn't works!

share|improve this question

closed as not constructive by cjc, SvW, John Gardeniers, HopelessN00b, mdpc Nov 13 '12 at 17:55

As it currently stands, this question is not a good fit for our Q&A format. We expect answers to be supported by facts, references, or expertise, but this question will likely solicit debate, arguments, polling, or extended discussion. If you feel that this question can be improved and possibly reopened, visit the help center for guidance.If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

2 Answers

up vote 3 down vote accepted

There are two problems with your approach.

Local Network and NAT

As your IP suggests you are in a private network behind a router.

You have to think of it like this: To counteract the limited number of IPv4 adresses you get normaly ONE public IP for your private internet connetion provided by your internet provider. To use this connection with more than one person you need a router device. This creates a local network with IP addresses that are only avalable withing your home network (the PCs that ar econnected to the router). If your surf the web the router translates your local adress to your public adress and you can surf. This is called Network Address Translation (NAT).

The problem is that I cannot reach your computer under 192.168.1.19 from here. I can only reach your public address. To make it possible for me to reach you, you need to setup port forwarding for port 80 to you local address (192.168.1.19).

Attention

It is very likely that your public IP changes every 24 hours. Therefore you would have to change your DNS settings every time you get new IP.

DNS Settings

You need to understand the Domain Name System.

Small overview: You send a DNS Query (sub.example.com) and the nameservers resolve your domain hierarchicaly. The DNS records (the information dnsserver needs to prcess your query) you need, to map a name to an IP, is called an "A record".

And keep in mind: Changes might take time. It might take days. It depends on the settings of your DNS

TL;DR

Setup port forwarding for port 80 on your router and set an A record for your public IP.

share|improve this answer
    
Well on my router I did this: on Port Range Forwarding port 80-80, protocol TCP & UDP, IP: 192.168.1.19. But how do I set an A record for my public IP? Oh and my public IP is static so I don't have to change the DNS I think. –  motash Aug 8 '12 at 14:38
    
Just look through your settings at name.com and find where you set records. The web interfaces differ between these services. You don't need to mess around with setting up your own nameserver if you just want a domain to point to your IP –  Christopher Perrin Aug 8 '12 at 14:45
    
I just did that, but when I go to OreadGames.com, there is a very strange website. And it is not directing to my server, although I did exactly what you said. But as you posted maybe I must wait, so I will check if it works tomorrow, thanks for your help anyway! –  motash Aug 8 '12 at 14:47
    
oreadgames.com points to 208.43.167.112. Is that your IP? –  Christopher Perrin Aug 8 '12 at 14:50
    
No my IP is 62.163.7.106 –  motash Aug 8 '12 at 14:52
show 2 more comments

You need to set up some DNS records for your domain. Just setting up BIND yourself isn't going to do anything at all...in order to publish a name to DNS:

  • you need DNS servers, and
  • you need to update your domain registration to point to those nameservers

Typically, most domain registrars (like name.com) provide you with DNS nameservers and a web interface for updating your domain records. It is generally much easier to use the nameservers made available by your registrar rather than setting up your own.

Name.com has a number of documents that focus on domain name management.

If you really want to run your own nameserver, rather than using the ones provided by name.com, take a look at this document...but I recommend you just use the name.com nameservers.

share|improve this answer
    
Well I followed this tutorial to setup a DNS server ulyssesonline.com/2007/11/07/… but that doesn't work, and the files on Name.com only point to things you can do inside the account, but I don't know how to use the information of that. –  motash Aug 8 '12 at 14:24
    
I've udpated the second link to something more appropriate...which was in the same section of the knowledgebase. The tutorial you followed tells you how to set up a DNS server, which is correct as far as it goes. Once you have a DNS server set up, you need to take the additional steps to tell the world about it. I think you'll find that the documentation available on name.com is more than sufficient. –  larsks Aug 8 '12 at 14:30
    
I can't change the nameserver to ns1.oreadgames.com, so I don't know what I should change it to.. –  motash Aug 8 '12 at 14:33
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.