Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am looking into a weird problem for some of the users (including me!) on my network.

Symptoms: When connected to wireless internet browsing fails. Trying to visit, for example, google.com via IE or Chrome will timeout and fail.

During this time, other services remain active. The connection never actually drops out. I'm able to ping external domains while browsing isn't working.

Weirdly, I have found an odd workaround.

Either, I wait a few minutes and eventually browsing begins to work again OR I launch a command prompt and ping an internal hostname. The second I start the ping command, I can hit refresh in any browser and my web pages begin to load.

I'm at a loss as to what would stop browsing, but let me to continue resolving names externally via ping or some such.

Any ideas about a starting point for investigation would be great.

This is in a Windows Domain environment with a 2003 DC (which is also DHCP and DNS).

share|improve this question

1 Answer 1

This may not be the cause in your case but we have been experiencing a similar issue on a client's entire domain (multi-site) - the wifi connects fine (strong connection) but the users (only some affected) cannot browse the web. Ping works in some cases and not in others.

We haven't confirmed a solution yet, but our diagnostics have led us to the cisco server for the wifi access points. The issue seems to be with DHCP leases as the laptop is getting the same ip address as it did on the previous attempt but according to the server it hasn't fully authenticated. This can lead to two laptops getting the same addresses - hence the strange behaviour.

I don't know if you have cisco as your wifi provider but either way I would ensure you have the latest firmware on your wifi hardware and latest drivers for the wifi adapters on your laptops.

I will update this post once we do the firmware upgrade just incase it affects anyone with a similar problem.

share|improve this answer
    
It's funny you mention DHCP leases. I've noticed some weird DHCP issues - I've had a few desktop PCs (when turned off for the weekend and booted back on the monday) coming up with conflicting IP addresses. I wonder if there's a connected issue. –  CraigE Aug 8 '12 at 15:21
    
Does your wifi setup issue the same range of IP addresses as your lan? - I would strongly consider (if you can) reserving an ip range (or even a completely seperate range) for wifi/lan. –  PJ42 Aug 10 '12 at 8:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.