Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I setup my Hyper-V under Windows 2008 R2 Standard. But i can´t access internet (network) in virtualized machines.

First. I setup the hyper-v using this manual http://www.howtogeek.com/103884/install-hyper-v-on-windows-server-2008-r2/

The first doubt its on step "Create Virtual Networks", my dedicated server show only one network adapter "Intel(R) 82580 Gigabit Network Connection #2"

I dont check this adapter because the warning message in window -> "We recommend that you reserve one network adapter for remote access to this server. To reserve a network adapter, do NOT select it for use with a virtual network"

What I use a dedicated server (I access the machine by RDP), and the settings of external IP address its typed in properties of this adapter "Intel(R) 82580 Gigabit Network Connection #2". If I check it option box in wizard, can lost my RDP connecting forever? (because I order a dedicated and dont access phisically the machine).

I´m scared to check this option and lose the connection with the server. Then I kept uncked the click next, finish.

After installed, I access "Virtual Network Manager", create a new virtual network of type External. Connected to "Intel(R) 82580 Gigabit Network Connection", I have two options "Intel(R) 82580 Gigabit Network Connection #2" and "Intel(R) 82580 Gigabit Network Connection", the adapter with final #2 have my static IP address configered, when I selected the option "Intel(R) 82580 Gigabit Network Connection" its a other adapter, possible created by Hyper-V.

I created my VM (windows xp) with the Virtual External Adapter, but when the windows start, the connection with internet fault. I try put my secondary IP address with gateway, dns, and mask subnet, but the problem its same.

Can anyone help to connect correct with the Internet in my VM, and setup my secondary external IP address?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Ernest,

First thing you want to double check is how many physical network ports do you have on this server. Is it one or more?

A. If you only have one port, then read this next section. Otherwise, skip to section B.

With only one physical network port, you must configure the network adapter for shared use by Hyper-V and the Management OS. When configuring the Virtual Network, you will need to check the box "Allow management operating system to share this network adapter".

If you are connected to the server via RDP, you will lose connectivity briefly while the configruation changes are saved. You may need to reestablish the RDP session if it doesn't come back by itself.

Once you configure this option, the static IP address you originally assigned to the physical adapter will be ported to the virtaul adapter created for use by the Parent Partition.

Now you can connect your VMs to the Virtual NEtwork you defined. In my case, it would be CorpNet.

B. Two physical network ports (based on your description, I think this is the option that applies for you).

If you have two ports, one can be used to manage the Parent Partition and the other can be used for VM traffic. This allows the traffic to be separated (security and performance). When you create your Virtual Network, select the adapter that does NOT have the #2 at the end and do NOT select the "Allow management operating system to share this network adapter" option. Ensure the network cable is plugged into both ports on the server. If you are configuring IP within your VM via DHCP, then make sure your DHCP server is up and running. If you are configuring it manually, then make sure you use the proper IP settings.

share|improve this answer
    
Thank you Harold Wong, the plan "A" worked perfectly. –  Ernest Aug 9 '12 at 11:17
    
Glad to hear my answer was helpful for you. –  Harold Wong Aug 9 '12 at 22:57

It sounds like you have a Dual Port Card and only one port connected to your network. Check the cabling to make sure both ports are connected. Also you will need to install the integration components in windows XP to utilize the synthetic network adapter.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.