Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am a dev-op (a software developer who has to do IT on the side). As a website developer, I create DNS host entries on my local Windows 2003 DNS servers - there are two DNS servers in the local domain - so that I can set up IIS7 websites on my Windows 7 development box.

My method is to add the given client's domain to a zone on my DNS server; copy across all the MX records from the primary nameserver; add a www A record; and then my own dev A record. This way users on my domain (graphic designers, etc) and I get to see the public website and the development website, but the public at large don't get to see the latter.

From time to time - which is a bit weird - I have a problem with Windows 2003 DNS resolving these entries. It adds my local domain (cazburo.co.uk) to the DNS search eg sc-asphalte.fr.cazburo.co.uk shown below:

------------
Got answer:
    HEADER:
    opcode = QUERY, id = 2, rcode = NXDOMAIN
    header flags:  response, auth. answer, want recursion, recursion avail.
    questions = 1,  answers = 0,  authority records = 1,  additional = 0

    QUESTIONS:
    sc-asphalte.fr.cazburo.co.uk, type = A, class = IN
    AUTHORITY RECORDS: ...

Appending a dot onto the FQDN ie dev.sc-asphalte.fr resolves correctly, but users don't expect to do this and browsers are not mad about it either giving bad host responses some of the time.

The rationale for appending a suffix onto the DNS query before attempting to resolve the query 'as is' first eludes me. However this is the behaviour I would like: attempt resolution 'as-is', then resolve with suffixes, go to fowarders, etc. Is there any way of achieving this with Windows 2003+ (I'll upgrade from Windows 2003 if necessary)?

Thanks.

Crispin

PS things that I have tried:

Other settings that may have a bearing:

  • the DHCP Scope Options for 005 Name Servers and 006 DNS Servers are set to the internal domain DNS servers.
  • all client computers use DHCP for network configuration
share|improve this question

1 Answer 1

The DNS client is "searching" for a record. This happens when whatever was typed in to the address bar returns no record (note: this "no record" response may be cached, not necessarily returned from a server). If any of the client's configured servers first responds with a "no record" response, then the client will cache that response and not try any additional servers. Once it hits that wall Windows by default will try the computer's primary DNS suffix (domain), and all connection specific DNS suffixes (assigned by DHCP usually, though you can manually configure them too) in that order. You can disable this searching by configuring the "list" of DNS suffixes and giving it an empty list. The client can be configured as such in the Control Panel, open the Properties of the Network Adapter(s) associated with your networks connection, open IP properties, Advanced button, DNS tab, and you'll see the options for DNS suffixes.

share|improve this answer
    
I did a go with changing the adapter settings earlier today but Windows 7 throws an error prompt 'The current setting of search method requires at least one DNS suffix' so I gave up with that. Also I've got some Apple Macs on the network, so I'm trying to keep the solution to group policy or the server side. I'm going to have to put back the 015 DNS Domain Name as one Mac user has already spotted that she can't get through to one of the IIS servers. –  CrispinH Aug 10 '12 at 19:25
    
What's really strange is that some DNS entries configured this way are working just fine –  CrispinH Aug 10 '12 at 19:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.