Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have set up a new SharePoint 2007 site with a Records Repository. We're using Exchange 2007 Managed Folders to route e-mails to this repository based on the 'label' attached to the e-mail as set in the Exchange 2007 journaling options.

E-mails added to a Managed Folder get sent to SharePoint, they end up in the "Submitted E-mail Records" list of the Records Repository. That's according to plan, but the e-mails are not routed to the respective document library as defined by the label.

Instead an error appears in the event viewer for every e-mail listed in the Submitted E-mail Records list, on every interval of the records repository schedule (set to every two minutes for testing purposes): Value cannot be null, parameter name: g.

Sending a document from the SharePoint site iself to the Records Repository via the Send To... link works fine, but e-mails get stuck in the list... We have set Document Libraries in the Respository with and without content types (with matching names with the Label and the Record Routing rule set). Any ideas what could be wrong?

This is in the event log:

Every two minutes the following error appears in the Application Log:

Source: Office SharePoint Server Category: Records Center Type: Error Event ID: 4975 User: N/A Computer: SPS2007

Description:

Value cannot be null. Parameter name: g

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

share|improve this question
    
What is listed as the source for "Value cannot be null, parameter name: g"? –  Adam Brand Jul 16 '09 at 16:48
add comment

1 Answer 1

I have fixed the problem.

It seems to be related to the Record Center being created in the same Site Collection as the Collaboration Site that was created. When you create a new Site Collection and create the Record Center in there, the whole process works without a hitch.

So instead of sps2007/repository/, I have created sps2007/sites/repository/ and that fixed the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.