Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've been attempting to configure a software raid1 using a pre existing Ubuntu 12.04 install by following the guide here. I successfully completed step 4 but then couldn't get Ubuntu to boot into the degraded raid device. I read somewhere that you need to run the following command

dpkg-reconfigure grub-pc

from within the raid config, so as root, after step 4 I ran the following commands:

mkdir /tmp/mntroot
mount /dev/md0 /tmp/mntroot
chroot /tmp/mntroot
dpkg-reconfigure grub-pc

this appeared to correctly update the grub.conf to the new raid setup.

On boot I can bring up the grub boot list and by pressing 'e' I can see the correct commands. The kernel I'm trying to boot into now also gives the correct UUID for the raid drive 'md0'.

Unfortunately if I try to go any further the system restarts.

I have tried going to the grub command line by pressing 'c' at the grub menu. This succesfully brings up the command line:

grub>

Unfortunately if I type ANY command, including 'help' and press enter the system restarts.

If anyone could help shed any light on this that would be greatly appreciated.

Marc

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.