Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The non www version of my site is not loading.....i strongly think its DNS and not nginx(I haven't setup an redirect in nginx yet .The www version works perfect

I don't use any cpanel atm and i don't want to use one either I followed this tutorial http://www.broexperts.com/2012/03/linux-dns-bind-configuration-on-centos-6-2/ Its exactly like the one in tutorial above except that i modified his domain to mine Here is my site http://www.leech4ever.com/ (Remove www from link and site won't load)

Please help me to solve this problem , i need both of the versions to work .I will redirect to version of my choice later Some extra info: OS - Centos 6 No control panel Guys please help me to solve this non www version of site not loading. Also the tutorial above don't say how to add slave nameserver(ns2).For me the ip of ns 1 is same as ns2. Notice: I am complete noob when it comes to dns , can you please give me setup by setup tutorial

Here are the dns configuration /etc/named.conf

// // named.conf // // Provided by Red Hat bind package to configure the ISC BIND named(8) DNS // server as a caching only nameserver (as a localhost DNS resolver only). // // See /usr/share/doc/bind*/sample/ for example named configuration files. //

options { listen-on port 53 { 127.0.0.1; }; listen-on-v6 port 53 { ::1; }; directory "/var/named"; dump-file "/var/named/data/cache_dump.db"; statistics-file "/var/named/data/named_stats.txt"; memstatistics-file "/var/named/data/named_mem_stats.txt"; allow-query { localhost; }; recursion yes;

dnssec-enable yes; dnssec-validation yes; dnssec-lookaside auto;

/* Path to ISC DLV key */ bindkeys-file "/etc/named.iscdlv.key";

managed-keys-directory "/var/named/dynamic"; };

logging { channel default_debug { file "data/named.run"; severity dynamic; }; };

zone "." IN { type hint; file "named.ca"; };

zone "leech4ever.com" { type master; file "leech4ever.com.fwd"; };

zone "0.168.192.in-addr.arpa" { type master; file "leech4ever.com.rev"; }; include "/etc/named.rfc1912.zones"; include "/etc/named.root.key"; leech4ever.com.fwd $ORIGIN leech4ever.com.

$TTL 3D

@ SOA luna380.startdedicated.com. root.leech4ever.com. (12 4h 1h 1w 1h)

@ IN NS luna380.startdedicated.com.

luna380.startdedicated.com. IN A 85.25.100.52

www IN A 85.25.100.52

leech4ever.com.rev

$ORIGIN 0.168.192.in-addr.arpa.

$TTL 3D

@ SOA luna380.startdedicated.com. root.leech4ever.com. (12 4h 1h $

@ IN NS luna380.startdedicated.com.

211 IN PTR luna380.startdedicated.com.

Just a question Accoding to me NS are ns6.nameserverservice.de. & ns5.nameserverservice.de then why hostname luna380.startdedicated.com. is in dns

You guys know better , please fix this for me

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

THe problem, as @Frederik Nielsen said, it's in the DNS. And, even if modify YOUR config, records aren't even pointing to your DNS Server. They point at ns5.nameserverservice.de.. To start configuring your DNS server, just go here and it will generate the zone file.

PLus, when the name server at ns5.nameserverservice.de. was configured, you probably added the zone as www.leech4ever.com, because the domains www.www.leech4ever.com and mail.www.leech4ever.com exist! When you added the zone it should be named as leech4ever.com, without www. on it. Just see that you can access via www.www.leech4ever.com

share|improve this answer
    
You are right in all ways dude but when i add domain leech4ever.com (without www) it says domain already registered.So i have no option but to to put domain as www.leech4ever.com –  Werulz Aug 12 '12 at 4:46
add comment

You have forgotten to create a A record for @.

Check out these dig's for more info: http://www.digwebinterface.com/?hostnames=leech4ever.com%0D%0Awww.leech4ever.com&type=A&useresolver=8.8.4.4&ns=auth&nameservers=

Post your DNS configuration, so it can be investigated further.

share|improve this answer
    
Thanks for the quick reply Frederik –  Werulz Aug 11 '12 at 16:11
    
Which file to edit to add the A record...Also please give an example –  Werulz Aug 11 '12 at 17:55
    
@Werulz According to your whois record, your DNS service is being handled by your hosting provider. You will need to use the tools provided by your hosting provider. –  Michael Hampton Aug 11 '12 at 18:03
    
just added dns configuration.....its a dedicated server .My friend just added the suggested NS .We could have changed it to ns1.leech4ever.com but dns has been propagated already so useless to wait more time.Frederik must be right –  Werulz Aug 11 '12 at 18:08
    
@Werulz as user1460016 correctly states, you have to make the changes at nameserverservice.de as it doesn't look like you are fully in charge of the DNS setup yourself. –  Frederik Nielsen Aug 11 '12 at 18:56
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.