Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Cant find any answers anywhere so here goes.

I am trying to CREATE a new virtual machine using the virt-install command from a console on a Debian wheezy install.

I keep getting the following output:

Starting install...
ERROR    internal error process exited while connecting to monitor: char device redirected to /dev/pts/1
inet_listen_opts: bind(ipv4,127.0.0.1,5951): Cannot assign requested address
inet_listen_opts: FAILED

I assumed that the port (5951 in this case) was being used judging by the error message and other sites I visited for an answer, but the same error occurs whatever number I use for the port. I cant see that port being listened upon in netstat either.

Anyone have any ideas what may be wrong?

share|improve this question
    
Is your lo interface up? –  Michael Hampton Aug 11 '12 at 19:59
    
You solved it Michael nice one :) If you add that as an answer, I'll make it the accepted answer and give you the points. –  chrismacp Aug 12 '12 at 15:21
    
Done :) Glad to hear it's fixed. –  Michael Hampton Aug 12 '12 at 16:44

1 Answer 1

up vote 2 down vote accepted

Check to make sure your lo interface is up and running properly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.