Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I tested connection using localhost (as it written in documentation) and connection was successful (I got opened terminal and SFTP)

I set port forwarding on the router. I am located inside network. There are no firewalls.

When I connect from different computer I get some problems. Client even can connect to the SSH server, but connection is immediatly interrupted after it has been established.

It's log: enter image description here

I can't make up any reason what can be a cause of the problem

Thanks, in advance!

share|improve this question
    
Does bitvise ssh server have an option to increase log verbosity? –  coincoin Aug 11 '12 at 22:20
    
unfortunately, no –  E6aTb_E6aTb Aug 11 '12 at 22:43
    
the same problem for freesshd too –  E6aTb_E6aTb Aug 11 '12 at 23:55

1 Answer 1

First, if you are using private/public key pairs, check the permissions on the authorized_keys file. The file should only be read/write for the user and in a directory that is read/write/execute by the user only. This should have been an issue durring the localhost test but it is always a good idea to check.

Try to telnet from the client to the port: you should get something like what I get when trying mine
SSH-2.0-OpenSSH_5.8p1 Debian-7ubuntu1
this will show that the ports are correct, open, and the daemon is running.

If you have turned off tunneled passwords (a good idea once you get it running) turn them back on until you can eliminate key issues as the problem.

If you can't get it running, i may need more info:
What port? I see you running on both 33934 and 58302. Which is correct?
Key or Password? Each has its own issues.
What does the log file on the server say? You can set OpenSsh's daemon to log more verbosely. It may be rejecting because of its own issues.
Is the Bitvise key in a format it likes?
Are you trying to SSH as root? This may (should) be turned off also.

share|improve this answer
    
hi, thanks you for your response. As client I use Putty programme on Lubuntu 12.04, my connection parameters imm.io/BQJm Log of client is imm.io/BQJx Full setups of client paste.org.ru/?seskac Computers are inside a local network, there is a router, its setups imm.io/BQJL and minus.com/lXpdhpBrtwPEj Server is working on Windows XP SP3. Firewall on Windows is disabled. As server is used KSH, log of it is paste.org.ru/?sz6iro Setups of KSH paste.org.ru/?24p7kj I don't use authorized_keys. –  E6aTb_E6aTb Aug 24 '12 at 19:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.