Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am a PHP newbie and wanted to setup a local host, so I installed Apache and MySQL using XAMPP. The first time it didn't work, I googled my problem and the reason was that Skype was also using port 80. I uninstalled both Skype and XAMPP and installed XAMPP again.

Now Apache is using port 80 and yet doesn't serve (I checked using netstat command on cmd and then comparing the PID number to the service).

Here is my etc/hosts file content:

127.0.0.1 localhost

::1 localhost

I am using 32-bit Windows 7 Ultimate edition.

Thanks in advance.

share

migration rejected from stackoverflow.com Aug 14 '13 at 21:28

This question came from our site for professional and enthusiast programmers. Votes, comments, and answers are locked due to the question being closed here, but it may be eligible for editing and reopening on the site where it originated.

closed as off-topic by Tom O'Connor Aug 14 '13 at 21:28

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must demonstrate a minimal understanding of the problem being solved. Try including attempted solutions, why they didn't work, and the expected results. See How can I ask better questions on Server Fault? for further guidance." – Tom O'Connor
If this question can be reworded to fit the rules in the help center, please edit the question.

    
do you have administrator privileges when running apache2? –  GeoPhoenix Aug 11 '12 at 14:40
1  
what does it give you? blank page?? page not found? –  Umair Khan Aug 11 '12 at 14:40
    
You can uncheck usage of port 80 and 443 (ssl port) for connections in skype options so it will not interfere with apache. Your hosts file does not need 127.0.0.1 localhost nor ::1 localhost. It's commented out in my hosts file –  Leon Kramer Aug 11 '12 at 14:42
    
@UmairKhan Yep Page not found. –  Anirudh Sudarshan Aug 11 '12 at 14:44
    
@AnirudhSudarshan you can always go to run httpd.exe via cmd from apache2 directory.. and see the error that displays, instead of guessing what it might be.. –  GeoPhoenix Aug 11 '12 at 14:52
show 1 more comment