Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I don't know much about BIND but I'm learning and my friend helped me setup my own name servers. He did this before and it worked for him so I think he forget a step and that explains why this isn't working. Anyways, we used webmin to setup bind and i'm pretty sure that's okay but I can post info just ask.

  • So my domain is: dustinschreiber.com
  • At my registrant, naemservers are set to: ns1.dustinschreiber.com and ns2.dustinschreiber (Each pointing to an IP address on my server, I have two IPs)
  • whois shows my name servers are set right
  • http://postimage.org/image/o6fz623cx/ (All records according to BIND, The blacked out ones are for a friend and irrelevant anyways)
  • I haven't made any changes to the systems files I've done all work through webmin so I'm not sure if I was supposed to change another file.
  • Doing nslookup ns1.dustinschreiber.com on the server returns no results but even after a few days and doing /flushdns on my computer it still returns the proper IPs for both NSs as well as typing them into my web browser. But I had my friend try and it timed out for him so maybe that's my problem but just adding as much info as I can

I can't think of anything else to post so just ask if you need more info. I have fiddled around with BIND through webmin but don't know what else to try and all tutorials I find on setting up BIND are by using the files (they also didn't work for me) but I am not afraid to use SSH (I am well experienced in it) to modify files.

Thank you for reading this! Can anyone offer any suggestions? It's been like two weeks so I know it's been updated through the DNS servers.

Its a CentOS 6 machine btw.

UPDATE

[root@dustinschreiber ~]# dig @199.168.139.127 dustinschreiber.com A

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.10.rc1.el6_3.2 <<>> @199.168.139.127 dustinschreiber.com A
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 23919
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;dustinschreiber.com.           IN      A

;; ANSWER SECTION:
dustinschreiber.com.    38400   IN      A       199.168.139.127

;; AUTHORITY SECTION:
dustinschreiber.com.    1800    IN      NS      ns2.dustinschreiber.com.
dustinschreiber.com.    1800    IN      NS      ns1.dustinschreiber.com.

;; ADDITIONAL SECTION:
ns1.dustinschreiber.com. 38400  IN      A       199.168.139.127
ns2.dustinschreiber.com. 38400  IN      A       199.168.139.148

;; Query time: 0 msec
;; SERVER: 199.168.139.127#53(199.168.139.127)
;; WHEN: Sun Aug 12 21:40:03 2012
;; MSG SIZE  rcvd: 121

UPDATE

I think I fixed it! Allow-query in named.conf was set to localhost (looking in the /var/logs/messages file showed hundreds of query attempts but it said they were denied) A bit more googling and research and I commented out the allow-query line and restarted BIND. (Default is allow-query { any;}; apparently) and it worked! I'm not sure how secure it really is like that but I think it's working alright. :D Well it works and I'm happy. :D You guys lead me in the right direction so now I know what I have to change to make nameservers for a startup company my friend is doing. Thanks everyone!

share|improve this question

migrated from stackoverflow.com Aug 12 '12 at 13:06

This question came from our site for professional and enthusiast programmers.

    
I get no reply from your nameservers. Did you maybe forget to adjust the firewall rules to allow DNS traffic? –  Andy Ross Aug 10 '12 at 22:33
    
As far as I know the firewall is off. –  Dustin Aug 10 '12 at 22:43
    
Is your bind service running on the server? Can you see if port 53 is listening by running netstat -nltp –  Chida Aug 12 '12 at 13:10
    
@Chida yes BIND is running. and listening on both my IP addresses on port 53 –  Dustin Aug 12 '12 at 17:30
    
@Dustin: It definitively looks like a access-right error. Do you have any allow-query or match-clients in your configuration files? –  petrus Aug 12 '12 at 17:46

1 Answer 1

up vote 2 down vote accepted

Your dns servers are refusing to answer :

$ dig @199.168.139.148 dustinschreiber.com A
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: **REFUSED**, id: 45216
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;dustinschreiber.com.           IN      A

$ dig @199.168.139.127 dustinschreiber.com A
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: **REFUSED**, id: 25080
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;dustinschreiber.com.           IN      A

So they are listening and working, but there might be an access-list in Bind that prevents clients to get the answer.

share|improve this answer
    
An access-list? Not that I can find at least. Looking in the conf file reveals nothing and Webmin I find "Access Control List" is empty. –  Dustin Aug 12 '12 at 17:33
    
Also, if I run the dig command you did on the BIND server itself (mind you I never edited the resolv file or the hosts file) I am presented with the updated info I posted in the question which leads me to think... well I have no idea actually :P –  Dustin Aug 12 '12 at 17:39
    
You got me going in the right direction (plus your the only one that left an actual "answer" I guess you would say) so I'm going to mark you as solution. Everyone else: read the bottom update on my original question for the full explanation and solution. Thank you once again! –  Dustin Aug 12 '12 at 18:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.