Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install Ajenti http://ajenti.org I've followed the instructions on their website but when I do:

yum install ajenti

I get this:

python26-greenlet-0.3.4-trunk.i386 from ajenti has depsolving problems
  --> Missing Dependency: libpython2.6.so.1.0 is needed by package python26-greenlet-    0.3.4-trunk.i386 (ajenti)
python26-gevent-1.0b2-trunk.i386 from ajenti has depsolving problems
  --> Missing Dependency: libpython2.6.so.1.0 is needed by package python26-gevent-1.0b2-    trunk.i386 (ajenti)
python26-lxml-2.3.3-2.i386 from ajenti has depsolving problems
  --> Missing Dependency: libpython2.6.so.1.0 is needed by package python26-lxml-2.3.3-2.i386 (ajenti)
ajenti-0.6.2-1.noarch from ajenti has depsolving problems
  --> Missing Dependency: /usr/bin/python26 is needed by package ajenti-0.6.2-1.noarch   (ajenti)
ajenti-0.6.2-1.noarch from ajenti has depsolving problems
  --> Missing Dependency: python26 is needed by package ajenti-0.6.2-1.noarch (ajenti)
Error: Missing Dependency: libpython2.6.so.1.0 is needed by package python26-lxml- 2.3.3-2.i386 (ajenti)
Error: Missing Dependency: python26 is needed by package ajenti-0.6.2-1.noarch (ajenti)
Error: Missing Dependency: libpython2.6.so.1.0 is needed by package python26-greenlet-   0.3.4-trunk.i386 (ajenti)
Error: Missing Dependency: libpython2.6.so.1.0 is needed by package python26-gevent-  1.0b2-trunk.i386 (ajenti)
Error: Missing Dependency: /usr/bin/python26 is needed by package ajenti-0.6.2-1.noarch    (ajenti)
share|improve this question

1 Answer 1

up vote 1 down vote accepted

The base CentOS 5 system includes Python 2.4, whereas Ajenti requires Python 2.6. Python 2.6 is however available in the EPEL repository, so you need to configure this before installing Ajenti.

share|improve this answer
    
Yeh i've installed python 2.6.7 Because when I do Python -V it says 2.6.7. Didnt install it with the EPEL repos though. I shall try it that way and let you know if it worked :) –  mattyh88 Aug 12 '12 at 20:23
    
@mattyh88 If you didn't install it using packages (using the same scheme as EPEL) then the dependencies aren't going to be met. –  mgorven Aug 12 '12 at 22:17
    
thx! It's working now :) –  mattyh88 Aug 13 '12 at 9:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.