Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have just installed Squid on my Ubuntu 11.04 system by entering

sudo apt-get install squid

I then edited /etc/squid/squid.conf and added

acl squid_network src 10.0.2.0/24
http_access allow squid_network
http_access allow all

after

acl purge method PURGE
acl CONNECT method CONNECT

I then went into Firefox, chose Edit:Preferences:Network:Settings

and made the following changes.

Manual proxy configuration
HTTP Proxy 10.0.2.2        Port 3128
Use the proxy server for all protocols
No Proxy for localhost:127.0.0.1

I then went to the terminal and entered

sudo service squid restart

which resulted in

squid start/running, process 3309

Now, when I go to FireFox and click on home to go to http://start.ubuntu.com/11.04/Google/?sourceid=hp

I get

The connection has timed out      


      The server at start.ubuntu.com is taking too long to respond.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer's network
connection.
 If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

I do not have this problem if I just use the system proxy settings.

Any assistance with this would be greatly appreciated,
Peter.

share|improve this question
    
What do your squid logs show? Any errors during startup? Do you see connections form Firefox? Are there any iptables rules on the system that would prevent Firefox from connecting to the proxy? –  larsks Aug 13 '12 at 0:22

2 Answers 2

The obvious issues I could see are:

  • IP Tables blocking connections, easiest way to test this is to temporarily disable any IPTable rules and seeing what happens with sudo iptables -X.

  • Check what Port the proxy is running under with in squid config under the tag http_port and make sure you are using the same port in Firefox

share|improve this answer
up vote 0 down vote accepted

Thank you to the people who answered my question.

My problem was HTTP Proxy 10.0.2.2. I was apparently supposed to use the host IP address, 192.168.1.6 in my case. I changed 10.0.2.2 to 192.168.1.6 and that has fixed the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.