Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I picked up some infiniband cards off ebay for development/testing purposes.

I was hoping that there would be some drivers available under windows 7, but it doesn't seem to be recognised by the OFED software which would seem to contain windows drivers. They are however immediately picked up by Ubuntu and drivers are loaded.

Are these cards supported under windows 7 at all?

mstflint under linux reports:

Image type:      Failsafe
FW Version:      4.8.930
I.S. Version:    1
Device ID:       25208
Chip Revision:   A0
Description:     Node             Port1            Port2            Sys image
GUIDs:           001a4bffff0c9374 001a4bffff0c9375 001a4bffff0c9376 001a4bffff0c9377
Board ID:         (HP_0060000001)
VSD:
PSID:            HP_0060000001

From what I can tell they are the following: HP IB 4X DDR PCI-e DUAL PORT HCA (HP part number 409376-B21)

share|improve this question

3 Answers 3

According to HP the following are supported.

Operating systems support Mellanox OFED 1.5.3_3.0.0 for Linux (64 bit)

RHEL 5, U5, U6, U7 in G7 servers U7 in Gen8 servers

RHEL 6 U1, U2

SLES 10 SP4,

SLES 11 SP1, SP2

Mellanox WinOF 3.0 for Microsoft Windows HPC server 2008 (64-bit)

Microsoft Windows 2008

Microsoft Windows HPC server 2008

Microsoft Windows HPC server 2008 R2

Mellanox EN (Ethernet Only) 1.5.7.2

RHEL 5, U5, U6, U7 in G7 servers U7 in Gen8 servers

RHEL 6 U1, U2

SLES 10 SP4,

SLES 11 SP1, SP2

Mellanox OFED for VMware (InfiniBand Only) 1.7.0

VMware ESXi 5.0

Mellanox EN (Ethernet Only) for VMware 1.5.7.0

VMware ESX 4.1

Mellanox EN (Ethernet Only) for VMware 1.6.1.2-1

VMware ESXi 5.0

QLogic OFED+ 7.0.1.0.43 for Linux (64-bit)

RHEL 5 U4, U5, U6, U7

RHEL 6 U1, U2

SLES 10 SP3, SP4

SLES 11 SP1

CentOS (Rocks) 5.4, 5.5, 5.6, 6.0

Scientific Linux 5.4, 5.5, 5.6, 6.0

share|improve this answer
    
I actually did eventually find out the answer. Only the ConnectX series of Mellanox cards are supported under windows. Infinihost are not. –  Matt Aug 16 '12 at 1:54
    
Which turns out to be wrong. See my new answer below. –  Matt Oct 11 '12 at 20:29
up vote 0 down vote accepted

Go here: Mellanox OFED for Windows (WinOF)

See the comment about InfiniHost cards

Note: MLNX_WinOF_VPI 3.2.0 should be used for ConnectX adapters family only. For InfiniHost and InfinHost III adapter family please use MLNX_WinOF_VPI 2.1.2. To download MLNX_WinOF_VPI 2.1.2, go to the Archive tab.

Download 2.1.2, install and viola!

If you do choose to use the 3.2.0 stack, no driver will be loaded against the card.

share|improve this answer

@Matt

Your list is not quite correct. According to the manual of the 409376-B21, the adapter is an Infinihost III ex (presumable a MT25208).

The mellanox website only lists the new Connect*-Infiniband adapters as compatible with ESXi 5. I tried an Infinihost III adapter with the MLNX-OFED-ESX-1.8.1.0.zip driver, but the adapter was not recognized by vmware ESXi 5.1.

Maybe someone with a (big) company in his background can ask Mellanox for the drivers source code of the old infinihost III adapters and make the code available. This way, the community can port the drivers to recent operating systems.

share|improve this answer
    
My question relates to Windows, not ESXi. Although ESXi is linux based, they build their own kernel. I recently found out it's quite old too. –  Matt Sep 27 '13 at 2:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.