Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the problem, that I am trying to automate some Informix database job via the crontab.
The job runs fine when done via the command line or processed via the at queue, but not via the crontab. The informix error "-23191 Unable to load locale categories" might indicate that the locale is not set.
How do I set the locale for cron jobs?

share|improve this question

The infomix locale need to be set in crontab

INFORMIXDIR=/home/informix
CLIENT_LOCALE=es_es.8859-1
DB_LOCALE=es_es.8859-1

0 15 * * *   /home/user/my-script.sh

The locale es_es.8859-1 is in my case, you need to check what is your locale.

share|improve this answer

The locale is usually inferred by the LANG and LC_* environment variables, so try setting these in the crontab itself. For example:

LANG=C
LC_ALL=C

0 * * * *   nobody  my-script.sh
share|improve this answer
    
Tried it, but it did not work yet. – weismat Aug 14 '12 at 9:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.