Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is more of a curiosity question then a problem at this point. I have resolved my problem which i'll post the solution that worked for me.

problem

I was getting rather slow authentication times when i attempted to log in from a windows 7 box (using putty) to a linux RHEL5 box. The initial connection request was fast. however, after typing in my username, the authentication time was very slow (exponentially obnoxious with my git pushes).

fix

I checked the logs and found ssh attempting to use GSSAPI authentication. my 20 second authentication timeout was obvious. i simply adjusted putty (and egit) to not use GSSAPI authentication. Login and authentication times were normal.

the question

my RHEL box was never touched. SSH configs (and timestamps confirmed) have not changed since over a year ago. My putty settings were never changed and AFAIK GSSAPi auth is defaulted to on in putty. I'm just incredible curious if anyone else has seen this issue? if GSSAPI was failing in the past because i don't use that feature, why all of a sudden did the timeout kick in and slow me down?

share|improve this question
add comment

1 Answer

I think it is more probably a DNS issue than GSSAPI. sshd likes prompt DNS responses to work promptly during connection phase... cause of logging and access checks.

share|improve this answer
    
i'll upvote you but do you have proof of this? it could be very related to useDns no which i have set and works. See related post –  austin Aug 16 '12 at 11:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.