Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server that no longer lists the current security relevant updates when using:

yum list-security or yum --security check-updates

At one point yum tried to update a package and couldn't figure out how to resolve the dependencies. Since that time, new security updates aren't showing (I know there are some because I run other server with similar software packages). Yum shows that the only security relevant package is the one that failed. What steps can I take to get yum working again?

yum update still works on any package I manually tell it to update.

share|improve this question
    
Have you run yum clean all and run yum update? –  Chida Aug 13 '12 at 14:24
    
@Chida - I'll try that. It sounds like a good idea –  JMC Aug 13 '12 at 14:29
    
@Chida - Thanks, that did it. If you want to post as an answer I'll accept it. –  JMC Aug 13 '12 at 14:31
add comment

1 Answer

up vote 4 down vote accepted

The following should do the trick,

    # yum clean all
    # yum update
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.