Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I just discovered this today and haven't been able to find any info elsewhere. On one of our labs running Ubuntu 8.04, I tried to switch to a virtual console (Ctrl-Alt-F[1-6]). Instead of switching to the console, though, the machine reboots.

I don't even know where to start trying to fix this, any ideas?

I ran all the updates and messed with the restricted drivers we were using and got nowhere. We're about to roll out 9.04 on our machines and hope that fixes it; if not, I'll be back here, I'm sure.

share|improve this question

4 Answers 4

up vote 3 down vote accepted

(Are you using X11 when this happens or are you switching between text consoles? Is your kernel tainted i.e. do you have any binary drivers installed?)

First, install all Ubuntu 8.04 updates (esp for the kernel) and test if the problem disappears. Probably you're not the first who runs into this (esp with this old distribution) and maybe there is already a fix available.

If the problem persists decide between trying the upgrade to Ubuntu 9.04 (the easy way) or trying to find the culprit of the problem (a little bit harder) by capturing a kernel panic: Connect your machine with a serial cable to a second machine (see Documentation/serial-console.txt in the kernel sources for an explanation). Alternatively you can try to capture the panic with netconsole (which sends the kernel panic as a UDP packet to a 2nd machine). Google "netconsole" and you'll find explanations how to do this.

Now, if you manage to capture the panic post the entire panic message here and chances are not bad that we'll be able to determine the culprit (you could e.g. search at kerneloops for the function name that appear at the top of the call trace or at the instruction pointer (EIP) address).

share|improve this answer
    
Go for upgradation / update of packages if kernel panic debugging looks scary. –  Saurabh Barjatiya Jul 16 '09 at 18:08

This can have many causes. One of the things to check would be if the file

/etc/default/console-setup

has a line

ACTIVE_CONSOLES="/dev/tty[1-6]"

in it.

Also check in /etc/events.d that the ttys are configured correctly and not all set in the same way as the control-alt-delete file.

Hope this helps.

share|improve this answer

You could check if you are out of diskspace (or memory for that matter). I have had logon problems when the root partition fills up.

share|improve this answer

txwikinger is right. If the pc works correctly I suppose someone (with root access) made a trick manipulating the configuration files for ctrl+alt+f1 :-)

above all check the file /etc/event.d/control-alt-delete and check this post

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.