Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We are attempting to install SQL Server 2008 R2 on a Windows 2008 R2 SP1 box. We keep running into errors at the end of the install - "the service did not respond to the start or control in a timely fashion". After that it shows "Failed" under Database Engine Services, SQL Server Replication, Full-Text Search and Reporting Services. The SQL Server service will not start after this completes.

I have found several answers about installing SQL Server 2008 SP1 prior to the install of SQL Server, so we tried that. But we keep getting the same errors. We also tried SP2 with the same problem.

We have also searched and gone through multiple articles about registry permissions, folder permissions, users accounts, etc. Nothing is working - same error every time. So far we have been working on this for 2 days.

Any ideas or advice would be greatly appreciated!

share|improve this question

Assuming it wasn't a UAC issue, have you tried installing on another box (or vm) to see if it happens there too? If it does, I'd say it's bad media.

share|improve this answer
Good idea, I will try that tonight and see what happens. – charnley Aug 14 '12 at 1:59
up vote 2 down vote accepted

This turned out to be a known issue with SQL Server 2008 R2 and Windows Server 2008 R2. The OS does not support SQL 2008 R2 out of the box, but does support it with SP1 or higher.

So I slipstreamed SP2 into the installation and it went through with no errors.

The article I used for this is here:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.