Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a Vista machine which I connect to regularly, and it no longer works. No config changes have been made in quite some time. The only changes along those lines are regular updates with Windows Update. Every time it pops up, I press Install. It is a legit copy of Vista. This problem started a week ago, after it had been working for months.

I have it set to listen on a non-standard port. If I run TCPView or netstat, I can see it listening on the port I specified. If I telnet to that port from the machine itself, I can start typing away, which proves that TCP connectivity is there.

Now, if I go to another machine on the lan, any other machine, I cannot connect to it. I used netcat on a FreeBSD machine to perform the same test as above, and the connection simply times out. If I run netcat on the Vista machine to open some random port, I can reach that port from the FreeBSD machine without issue, so communication between the two machines is fine.

I do not have any firewalls setup on the Vista machine. There is Windows Defender, but I am never prompted to allow Remote Desktop, and given that one of the main EXEs for Windows does the work, I don't see how Windows Defender could be having an effect on it, or how I would configure it.

I am out of ideas. Why won't Remote Desktop accept incoming connections? I've tried rebooting, of course.

share|improve this question
    
Where do the incoming connections come from? Vista/7 or an XP machine? –  Ryan Versaw Jul 16 '09 at 17:31
    
From an XP machine. Even still, basic TCP connectivity to the remote desktop 'daemon' is not working. –  Zimmy-DUB-Zongy-Zong-DUBBY Jul 16 '09 at 17:43

7 Answers 7

up vote 1 down vote accepted

Check Windows Firewall. Even if you turn it off, sometimes, in some environments, a single update will turn it back on. Happens all the time where I work.

You don't happen to have Microsoft Firewall Client to ISA Server enabled do you? I would doubt that you do but that puppy never lets RDP work until after you have established a connection.

share|improve this answer
    
You win! Windows Firewall had re-enabled itself after an update. –  Zimmy-DUB-Zongy-Zong-DUBBY Jul 17 '09 at 13:25
2  
Woohoo, how about an accepted answer as a prize :) –  Terry Jul 17 '09 at 17:41

Gotta be something in the Windows firewall, or of course the Remote Desktop settings in the Remote tab of System Properties.

share|improve this answer

Sounds like a firewall issue to me. To test the theory:

  1. Can you ping the machine?
  2. From an outside machine, can you telnet to port 135?

If #1 and #2 work, then it would be something with Remote Desktop. Otherwise it would be a firewall issue.

share|improve this answer

Since Remote Desktop was working before, this is probably not your problem, but I have seen video drivers cause Remote Desktop to fail. If you have updated your video drivers lately, you might try doing it again to a newer version if one exists, or downgrading.

share|improve this answer

On the system you're trying to connect to: If you right click on My Computer, then go to Properties, then to the Remote tab, which radio button is selected? Is the issue resolved if you select the "Allow connections from computers running any version of Remote Desktop (less secure)" ?

What is the version of the terminal services client on the client machine (your XP machine)? Is the issue resolved if you update the TSC to the latest version?

share|improve this answer

I would just login to the "Remote Desktop Manager" tool on the server your connecting to and disconnect any stray inactive sessions.

If you have another "Server" machine nearby you can open the Remote Desktop Manager on that machine and then "connect to remote computer" and you can remotely logoff the stray sessions.

share|improve this answer

When you have problem with remotedesktop use Teamviewer4 is very easy and better then REmote desktop.

Both must download Temviewer4 and start one als host and one als guest and give the Nr. and PW over Skype or, E-Mail and you can connect!

----Stooni

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.