Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've just had an issue arrise that I cannot seem to solve. I recently set up a Windows Server 2008 DC with DNS and DHCP and all has been working fine, but I discovered today that when I go into the DNS Manager I get the following issue:

DNS. Access was denied. Would you like to add it anyway?

I choose the option to connect to the local computer as that is where the DNS service is running, and I have tried using the FQDN with no luck.

The DNS services have been restarted with no effect, and I have tried adding the Administrator group to the DNSAdmins group but this didn't help either. Also I changed the ACL for the DNS object in the Active Directory Users and Computers to give Administrators full access but this didn't help either.

The domain isn't fucntioning properly as a result, with slow logins now and new GPOs not being pushed. (I'm assuming as the Windows 7 clients cannot map the server name with the IP maybe?)

I've checked the Event Log for the DNS and these are the most common errors:

1) The DNS server was unable to open Active Directory

2) The DNS server has encountered a critical error from the Active Directory. Check that the Active Directory is functioning properly. The extended error debug information (which may be empty) is "". The event data contains the error.

Any suggestions would be appreciated.

Thank you,

Jake

share|improve this question
    
In general without DNS running Active Directory is sucky. It most certainly sounds like the authorization of DNS to make AD changes and vice versa is broken. –  Brent Pabst Aug 15 '12 at 19:57
    
I fixed this issue - it seemed the host file had been changed and the localhost settings had been hashed out resulting in the DNS access denied issue. –  Jake Elsley Aug 16 '12 at 20:36
    
You can post your resolution as an answer to this question. Its perfectly acceptable to post your own answer to your question. That way people know exactly what fixed the issue. –  Brent Pabst Aug 17 '12 at 13:43
1  
I didn't know about that, but I have done know. Thank you. –  Jake Elsley Aug 18 '12 at 18:28
add comment

1 Answer 1

up vote 1 down vote accepted

In my case, the hosts file (c:\Windows\System32\drivers\etc\hosts) had the following two lines hashed out:

127.0.0.1       localhost
::1             localhost

They need to be like the example above for the DNS server to funtion properly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.