Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have strange problem...

I can not access to my webserver from other computers.

I can not even access from server itself if I use IP address different than, localhost, or (ip address of network card).

Error I;m getting is :

The requested URL could not be retrieved

BUT, I noticed that I can access to server from itself if I use lynx web browser(!).

My html page does not contains anything but simple text on it (no images or Flash).

I tried to disable firewall, but result is always the same.

Can you give me advice how to solve this?

UPDATE: result of netstat -lnp | grep 80 is:

[root@digital ~]# netstat -lnp | grep 80
tcp        0      0    *               LISTEN      3492/httpd          
tcp6       0      0 :::38015                :::*                    LISTEN      733/rpc.statd       
unix  2      [ ACC ]     STREAM     LISTENING     18084    1116/dbus-daemon     @/tmp/dbus-du7H0oKPGU
[root@digital ~]# 
share|improve this question
How are you trying to access your server (using its DNS name or using a public/private IP)? You need to be more specific in your description. – Khaled Aug 14 '12 at 12:12
I'm trying to access to it with IP address – user48058 Aug 14 '12 at 12:15
Can you ping this IP address? Can you access it locally from same machine? Can you access it locally from same subnet? – Khaled Aug 14 '12 at 12:25
As I said, I can access to webserver without problem using Lynx. Yes, I can ping server from other machines. Also, I did not mention that I can access to server's services like Samba or NFS. – user48058 Aug 14 '12 at 12:28
user 48058, forgive me for mentioning this, but you you have asked 24 questions on SF and, while nearly all have answers, you have accepted an answer for only eight. Local etiquette is that after a reasonable time, you accept the best answer for any given question, and that helps drive SF's reputation system. You don't have to do this, but as a result we see a warning "35% accept rate" by your username. That warning may discourage some people from answering your questions. If you had time to go through your old questions and accept an answer for each, that would be good. – MadHatter Aug 14 '12 at 12:36
up vote 0 down vote accepted

I solved this one.

Problem was that in local network, where two PC's with same name (new box was one of them).

When I pluged off network cable from the other, everything started to work.

What I do not understand is why it did not worked, because IP address of new PC was unique (both local and global), and I was not able to access to it neither with IP nor the URL.

What to say, except - you learn every day something new...

Thank you all on your help.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.