Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I get this error when running Start/Stop/Restart-CacheCluster commands in Caching Administration Windows PowerShell console:

ErrorCode:SubStatus:Operation was aborted because user selected not to enable Cache with secondaries.

What am I missing here? Microsoft help does not list this error code here. Running v.1.1 of AppFabric on Windows7 x64 machine.

EDIT: I have a single host, but am running in cache cluster. Also this set-up used to work a couple of days before, but unfortunately can't tell what actions exactly led to it stopping working.

share|improve this question
add comment

1 Answer

The secondaries feature of the caching mechanism has to do with High Availability for the cache cluster. Based on your description it looks like you only have a single host, therefore you don't actually have a cache cluster. What if you try the start/stop/restart-cachehost commands instead?

Also, are you sure you have actually setup a cache-cluster and have used the use-cluster command before trying to issue a command?

BTW, v1.2 is also out which may improve some of the messages and functionality, it did for me.

share|improve this answer
    
If I tried start/stop/restart-cachehost - I get completely the same exception as with cluster. Although you are right regarding single host. I haven't used "use-cluster" command, but assume it was used by configuration tool. When I tried using it manually - I got Use-CacheCluster : Method not found: 'System.String Microsoft.ApplicationServer.Caching.Utility.GetInstallPathFromRegistry()'. Therefore I tried reinstalling 1.1 version. Which for some reasons also did not work. So ended up in using v1.0. Can't find v1.2 - is it available publicly? –  Paulius Aug 15 '12 at 8:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.