Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a non-domain network with a Windows Server 2008 R2 Foundation here.

All shares except one work flawlessly, with the users having the correct rights. This happens from BOTH clients, one a Windows 7 and one a Windows XP machine.

Let me elaborate:

I have a share called "data" here. The share contains subfolders, these subfolders are being mapped to drives on the clients. All folders below the data folder inherit the rights from it.

For example:


These are two folders of programs which store their data in access MDBs and flat files (the company only has two users and the programs are explicitly stated as being simultaneous multi-user capable. Hell "vito" uses a MSSQL db, this folder contains additional files so w/e).

And now on to what I can access:

O: (\\mbssv01\data\omniwin) -> works flawlessly
I: (\\mbssv01\data\various) -> works flawlessly
V: (\\mbssv01\data\vito)    -> ACCESS DENIED when trying to change ANYTHING 
                    (You need to receive permissions from mbssv01\Administrator)
\\mbssv01\data\omniwin      -> works flawlessly
\\mbssv01\data\various      -> works flawlessly
\\mbssv01\data\vito         -> works flawlessly
\\mbssv01\data              -> works flawlessly

What. The. Heck.

I tried to reset all permissions to the vito folder, up to the point of giving EVERYONE full access to the data folder (the vito folder and ALL other folders INHERIT the rights from the data folder).

I tried mapping the drive to the IP of the server, does not work (direct access does though).

share|improve this question
Any chance the drive is being mapped with different credentials? – Grant Aug 14 '12 at 14:13
@Grant The logged in users on both PCs are existant on the server with the same password... How do I find out if it logs them in with different credentials? – sinni800 Aug 14 '12 at 14:19
From the 2008 server, go to adminsitrative tools->share and storage management, click manage sessions. That will show you what users are connecting. manage open files will show you the user and file being accessed if you open a file on the trouble share first. – Grant Aug 14 '12 at 15:32
up vote 1 down vote accepted

Have you checked the share permissions (properties->sharing->Advanced Sharing) to make sure that the account in question has "change"? It looks like your NTFS permissions (\server\share) work fine which is what makes me think the share permissions might have changed. I have seen "simple file sharing" screw up and not change share permissions if you change the NTFS permissions.

share|improve this answer
I gave all users that needed it "change" explicitly, again... See the EDIT by the way!# – sinni800 Aug 15 '12 at 8:15
This is probably what made it, in addition to re-setting all the mappings to use the correct user name and password – sinni800 Aug 15 '12 at 8:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.