Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to get the final step of an unattend install working.

I have 2 images:

boot.wim

install.wim

I've added drivers to both, and the reference install wim works fine with included programs and everything. I've created an unattend.xml file for install.wim which sets locale, language, etc. That's all working fine. However, I still have to "attend" the install as the PXE > boot.wim image asks for language and partition stuff.

I'm trying to create another unattend.xml for the boot.wim file (which is ripped directly from OEM disk from sources folder), but in WSIM, when I add the boot.wim image to the image manager (Windows 7 Setup or PE), there is no amd64_Microsoft-Windows-Setup/ component and thereby can't set things like language, partitions, and select the install image.

There are limited options in the componenets folder mostly related to networking.

Am I missing something?

As an aside, now that I've got this mostly working, I came across MSFT Deployment Toolkit... It looks promising, but am hesitant to jump in after spending all of this time on WDS. Should I go ahead with it? Any big benefits?

Thanks.


EDIT:

So, I have 2 images

boot.wim <- ripped from /Sources of OEM CD
- does not have unattend.xml
- can boot from (can choose PE or Windows setup)
-- PE only has option to capture, not install (if I remember correctly -- was so many reboots ago at this point ;)

install.wim <- captured image from sysprepped machine with various programs installed
- has unattend.xml (which works once I get into it via boot.wim) - can't boot

install.wim unattend.xml:

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
    <servicing></servicing>
    <settings pass="oobeSystem">
        <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="xxx" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <InputLocale>en-US</InputLocale>
            <SystemLocale>en-US</SystemLocale>
            <UILanguage>en-US</UILanguage>
            <UILanguageFallback>en-US</UILanguageFallback>
            <UserLocale>en-US</UserLocale>
        </component>
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="xxx" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <OOBE>
                <HideEULAPage>true</HideEULAPage>
                <NetworkLocation>Work</NetworkLocation>
                <ProtectYourPC>2</ProtectYourPC>
            </OOBE>
            <UserAccounts>
                <AdministratorPassword>
                    <Value>password123lol==</Value>
                    <PlainText>false</PlainText>
                </AdministratorPassword>
                <LocalAccounts>
                    <LocalAccount wcm:action="add">
                        <Password>
                            <Value>passwart==</Value>
                            <PlainText>false</PlainText>
                        </Password>
                        <Description>Local Admin</Description>
                        <DisplayName>BOSS</DisplayName>
                        <Group>Administrators</Group>
                        <Name>Tony Danza</Name>
                    </LocalAccount>
                </LocalAccounts>
                <DomainAccounts>
                    <DomainAccountList wcm:action="add">
                        <Domain>allMyDomainsAreWorkgroups</Domain>
                    </DomainAccountList>
                </DomainAccounts>
            </UserAccounts>
            <TimeZone>Eastern Standard Time</TimeZone>
        </component>
    </settings>
    <settings pass="specialize">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="xxx" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <WindowsFeatures>
                <ShowMediaCenter>false</ShowMediaCenter>
                <ShowWindowsMediaPlayer>false</ShowWindowsMediaPlayer>
            </WindowsFeatures>
            <ComputerName>Fonz</ComputerName>
            <ShowWindowsLive>false</ShowWindowsLive>
            <ProductKey>1234</ProductKey>
            <RegisteredOrganization>Jim's Bob Store</RegisteredOrganization>
        </component>
    </settings>
    <cpi:offlineImage cpi:source="wim://TI-86/reminst/images/install.wim#WIN7" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>
share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

There is no WindowsPE pass in your unattend. The very first example in this article is an example of a WindowsPE pass for WDS that should help you get past those initial prompts for language and setting up the hard drive. If you continue using MDT, you don't have to set much of this in the unattend file, since you can do all of this in the Task Sequence, and using the MDT LiteTouch.wim files as your boot images in WDS will let you choose the Task Sequence upon PXE boot. More information on the WindowsPE pass can be found in this article.

share|improve this answer
    
So I'm still not clear then... I should have set the unattend.xml that I created in WSIM for install.wim on my boot.wim? Or if I had the PE pass in the xml file it would have let me use the install.wim to boot with? Or I should have used 2 unattend.xml files; one for boot.wim and another for install.wim? –  stormdrain Aug 15 '12 at 20:08
    
I'm sorry for not being clear. The boot.wim needs no unattend. When you PXE boot, you should end up with a list of boot images, and once you pick one it will bring you into the WDS wizard to pick the install image. The unattend should be set for the install.wim. –  WinOutreach4 Aug 15 '12 at 21:41
    
Right. So we have now come full circle :) When I boot via PXE into boot.wim (the one ripped from OEM CD), the first screen I am met with is the language selection. Then on to domain credentials, then on to selecting install image, then partitioning. The OP was asking about an unattend.xml for these questions (which I believe you answered with your first link in this answer with the 2 unattend.xml examples). I'm not going to test it though since MDT is working fine. Thanks! –  stormdrain Aug 16 '12 at 15:02
    
@ancillary My apologies, I found what you are after. There CAN be an unattend file for each architecture in WDS. This is not specific to the boot image, but all boot images per architecture. Right click on your server (in the WDS snap in) and choose properties, then go to the Client tab, you can set an unattend file per architecture. WDS will use this to set those fields that you are seeing. Figure 5 in this article has details. I apologize for the mis-information. MDT has spoiled me, and I forgot all about this until I tested in lab –  WinOutreach4 Aug 16 '12 at 16:53
    
@ancillary The one thing missing from that article is to put in the WillShowUI element with a setting of Onerror under the SetupUILanguage element. For example: <SetupUILanguage> <WillShowUI>onerror</WillShowUI> <UILanguage>en-UK</UILanguage> </SetupUILanguage> –  WinOutreach4 Aug 16 '12 at 17:26
add comment

I went ahead and installed/setup MDT. I was able to bring over the install.wim that I had created with WDS so that was a huge help.

The client install process still isn't automated, but it is nicely streamlined. I would have had to still get the domain join process working in WDS (or log into each machine and join that way) and using WDS I was left with multiple users on the machine (one was in the install.wim, and would be asked to create another in the install process). I'm sure there are ways around all that, but with MDT, I get a few simple screens (admin pass; domain and domain join; OU) and am off and running.

A bonus to having WDS already set up, I could import the boot image created by MDT into WDS to PXE boot clients into the MDT PE.

PS, I've come across more alphabet soup while reading docs for this stuff...it seems to have warn off on me ;)

All that said, if anyone has an answer, I'd appreciate it. Otherwise, I'll accept this as the answer when I can.

Thanks.

share|improve this answer
    
MDT is the way to go! Your boot.wim was asking for language and partition information? That's odd, since the boot.wim should be WindowsPE and should create a RAM drive for itself. The language and partition information can be put into the WindowsPE pass of the unattend for the install.wim. Can you post your unattend file? –  WinOutreach4 Aug 15 '12 at 18:21
    
Well it would start up on the "My language is..." select box (English was not highlighted--but was only a few below the selected lang) then after selecting English would proceed to the partition screen. Re: unattend.xml; I never got to the point of making one (for boot wim). I suppose there might be a default boot unattend.xml file for WDS, but I don't know. In the WDS server properties, enable unattended install is not selected for client (again, didn't get that far). So far am digging MDT; still fighting some battles, but like it. Thx –  stormdrain Aug 15 '12 at 18:36
    
Right, I believe that is the start of Windows Setup, which would be using the unattend that you have for the install.wim. Can you post the unattend for the install.wim? Also, feel free to ask anything about MDT. –  WinOutreach4 Aug 15 '12 at 18:46
    
Ah. Didn't try using the unattend I created for install.wim on the boot image. At any rate, edited the question above with the xml file. Haven't hit any deal-breakers with MDT yet... just a learning process. Wish the docs were more...coordinated maybe? Found most of the helpful stuff on technet and forums; mostly for older versions that pointed me in the right direction. –  stormdrain Aug 15 '12 at 19:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.