Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been doing everything the instructions say http://www.postfix.org/MILTER_README.html and I was able to build, configure and run dkim-filter but postfix doesn't seem to call it.

I've got this in my main.cf

# DKIM
milter_default_action = accept
milter_protocol = 2
smtpd_milters = unix:/etc/postfix/dkim-filter.sock

and I set dkim-filter to read from that same file descriptor, no errors anywhere, but I don't get any dkim headers in the mail I send through postfix. Is there something else I have to turn on?

This is on solaris 10. postfix 2.3.20060611

share|improve this question
    
I think I just figured out my problem. wikipedia says: Milter support was added to Postfix 2.3.0 released July 12, 2006 I'm a month early. :-( –  Stu Aug 14 '12 at 20:41
    
okay we upgraded to 2.8 still nothing. Why no love from milter? –  Stu Aug 14 '12 at 21:20

1 Answer 1

Okay so I got it to answer. I am sending a message via smtp to postfix, yet it only worked when I added the non_smtpd_milters entry to main.cf not just smtpd_milters.

Lesson learned there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.