Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install MySQL 5.6 on CentOS 6.3 64bit using the .rpms provided by MySQL. I downloaded all the 64bit linux rpms into /usr/local/src/mysql and performed rpm -Uvh *.

The installation gave an error which I cant find out the error msg anymore. So I tried doing rpm -Uvh * again and it says

Preparing...                ########################################### [100%]

package MySQL-devel-5.6.6_m9-1.linux2.6.x86_64 is already installed
package MySQL-embedded-5.6.6_m9-1.linux2.6.x86_64 is already installed
package MySQL-shared-compat-5.6.6_m9-1.linux2.6.x86_64 is already installed
package MySQL-shared-5.6.6_m9-1.linux2.6.x86_64 is already installed
package MySQL-client-5.6.6_m9-1.linux2.6.x86_64 is already installed

Doing rpm -e MySQL* states that they are all not installed:

error: package MySQL-client-5.6.6_m9-1.linux2.6.x86_64.rpm is not installed
error: package MySQL-devel-5.6.6_m9-1.linux2.6.x86_64.rpm is not installed
error: package MySQL-embedded-5.6.6_m9-1.linux2.6.x86_64.rpm is not installed
error: package MySQL-server-5.6.6_m9-1.linux2.6.x86_64.rpm is not installed
error: package MySQL-shared-5.6.6_m9-1.linux2.6.x86_64.rpm is not installed
error: package MySQL-shared-compat-5.6.6_m9-1.linux2.6.x86_64.rpm is not installed

I tried starting mysql with /etc/init.d/mysql start and /etc/init.d/mysqld start but the error returned was no such file or directory.

I tried rpm --rebuilddb and tried installing and removing but get the same error.

I'm kind of stuck now as to what to do next. Any suggestions?


Update

I managed to get mysql installed by uninstalling and reinstalling the rpm.

Now when I try to start mysql,

/etc/init.d/mysql start
Starting MySQL.The server quit without updating PID file (/[FAILED]mysql/localhost.localdomain.pid).`

I tried mv /etc/my.cnf /etc/my.cnf.bak and /etc/init.d/mysql start but that gave the same error.

share|improve this question
    
Why aren't you using your package manager? –  jamieb Aug 15 '12 at 2:05
    
My package manager yum does not have the version of MySQL 5.6 that I want, only 5.1. –  Nyxynyx Aug 15 '12 at 2:09
    
rpm -qa --qf "%{n}-%{v}-%{r}.%{arch}\n" | grep -i mysql? –  quanta Aug 15 '12 at 2:54
    
@Nyxynyx spoiler: you can use yum install on .rpm files –  Joel E Salas Aug 15 '12 at 3:12
    
tail -20 /var/log/mysqld.log? –  quanta Aug 15 '12 at 4:07
show 2 more comments

3 Answers

up vote 2 down vote accepted

Do you have SELinux enabled? It's possible that the MySQL packages are not built to play nice with SELinux (not uncommon for 3rd party packages) and that it is blocking access to creating the PID file. A quick and dirty test would be to set your SELinux context to Permissive (or Disabled)

# setenforce permissive

If that is not the case then have a look at the file permissions themselves.

For more information on SELinux:
Red Hat SELinux Documentation for RHEL6
SELinux Project Wiki

share|improve this answer
add comment

Querying the rpmdb uses the package name, not the package filename. You can get the package name from a package file with rpm -qp --qf "%{name}\n" <file>.

share|improve this answer
add comment

The packages are probably installed, but if they're the ones you downloaded from mysql.com then the actual package names are in all lowercase, even though the file names are in mixed case.

With that out of the way, the mysql.com packages are not 100% binary compatible with CentOS and a lot more than this will likely break. If you don't absolutely need 5.6 then it's probably best to use 5.5 from a trustworthy repo such as remi, until such time as compatible packages become available.

share|improve this answer
    
I require the FULLTEXT feature of Innodb in 5.6. Updated original post! –  Nyxynyx Aug 15 '12 at 3:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.