Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

For some reason, I am getting automatically logged out of one of my shells on one Solaris box but not on the other one. I don't seem to have any bash variables set to auto logout. What else should I check?

share|improve this question
add comment

5 Answers

the auto logout is happening due to the IdleTimeout variable is set in /etc/ssh/sshd_config

I believe if you have KeepAlive set in your .ssh/config then it should stop (I haven't tested this though, so ymmv).

share|improve this answer
add comment

I assume you checked for the TMOUT variable in your bash session, correct?

Is there a firewall between your ssh client and the Solaris server in question? It might be dropping you after some amount of inactivity. If so, you could modify the sshd_config on the server and add the KeepAlive and ClientAliveInterval settings.

share|improve this answer
add comment

I've found that Cisco devices in their default configuration can cause this. Do you have different Cisco devices between you and each server?

share|improve this answer
add comment

Try setting ServerAliveInterval 600 in /etc/ssh/ssh_config on your client machine.

share|improve this answer
add comment

Check the /etc/default/login (TIMEOUT) and /etc/profile (TMOUT) files.

They have timeout settings for the login shell.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.