Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a website ( http://www.direshouseofsport.com ) that was working properly until today. Suddenly, the website will not let me login and my browser throws the following error:

The connection was reset. The connection to the server was reset while the page was loading.

In the error logs, I see: [Thu Aug 16 00:10:05 2012] [warn] RSA server certificate CommonName (CN) 'localhost' does NOT match server name three times.

The website seems to have lost all its styles too. I am on a shared host, in my public files I cannot access index.php (the browser throws the same error as above), and my control panel is DirectAdmin.

I didn't touch anything in my website so I thought this could be a server error. Do you guys have any idea what is happening?

share|improve this question
    
Looks fine to me, have you tried clearing your browser cache and reloading it? Also, is your browser requesting HTTP or HTTPS? The error you're getting in the logs is only a warning and shouldn't really affect anything if you're not using HTTPS. –  James Yale Aug 16 '12 at 9:30
1  
for future, try: downforeveryoneorjustme.com –  Sirex Aug 16 '12 at 9:38
    
Thank you guys. @JamesYale I cleared the catch, but still I see the site without css and I couldn't also login in to the pages login feature anymore. Is there anyother way? I also used Crome, but still the same problem. All other sites work. I don't know if this is a right question here, but can you suggest me ways? Thanks again. –  mika Aug 16 '12 at 10:03

1 Answer 1

As the site is working for others, including myself, the conclusion must be that the problem is at your end. The log entry referring to the certificate is common on shared hosts, where the system will never have the same name as your site and certificates are commonly shared amongst clients. This should produce a warning for any client that connects via HTTPS but can be ignored if your site is just HTTP.

share|improve this answer
    
so I guess you can see this website with the full style (?), in that case, I will have to clear the catches from my browser (?) or do you suggest anyother solution? thanks. –  mika Aug 16 '12 at 9:47
    
Do you have any other caches under your control, such as a proxy? Clearing the cache(s) should be the first step whenever a web site doesn't display correctly. –  John Gardeniers Aug 16 '12 at 10:14
    
I don't use proxies and I cleared the catches both in the chrome and firefox, but weirdly enough I can't login at direshouseofsport.com/login, it throws 'The connection was reset' in Firefox and the website comes without the style, and when I see the links on Firebug, it shows that the links to the styles is redirected to some other folder, when I edited it on Firebug it works, but I couldn't edit the source file since this problem is only in my computer. Any ideas? –  mika Aug 17 '12 at 9:53
    
Without seeing the code I have no idea. –  John Gardeniers Aug 17 '12 at 9:55
    
w/n I load the index (w/h ends up without styles),Firebug says This element has no style rules.You can create a rule for it.when I see the code with 'ViewSource' on the website,there are style links like this´<link rel="stylesheet" type="text/css" href="/index.php/tools/css/themes/house_of_sport/css/960_24_col.css" />´ in w/h when I click that the browser displays 'the connection was reset'. And the link to this style is not on the right directory, it is found in different directory. Of course, when I change the link on Firebug it starts rendering the styles onto the browser.does this help? –  mika Aug 17 '12 at 11:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.