Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i ssh to my remote centos sever as hugemeow, then i run sudo ls, then error happens:

[hugemeow@home ~]$ sudo ls
**audit_log_user_command(): Connection refused**
httpd

hugemeow is in /etc/sudoers, with the config as the follows:

hugemeow ALL=(ALL)     ALL

what's wrong with the msg showned above?

share|improve this question
    
rpm -qa| grep sudo? –  quanta Aug 16 '12 at 10:41
add comment

1 Answer

up vote 2 down vote accepted

The error you're seeing isn't important; it means that sudo is trying to connect to a local auditd server but that one isn't running. You'll note that the sudo command worked anyway, despite the error. This message should be suppressed in newer versions of sudo (according to Fedora bug 401201, this was fixed back in 2010).

In theory, making sure that auditd is running on your system should make the error go away.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.