Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We are trying to setup an unattended install of windows 7 to a gpt partition on a Lenovo U410, which has UEFI bios.

This webpage outlines how to format the disk for GPT. If add the default configuration, from the page, to the autounattended.xml file I get the error:

Windows cannot be install to this disk. The selected disk is of GPT partition style.

If we use the, webpage's, recommended configuration from the above page we get an 0x00042465 (VDS_S_EXTEND_FILE_SYSTEM_FAILED) error, outlined here

This is our xml file:

<?xml version="1.0" encoding="utf-8"?>
<!--This answer file generated by RT Seven Lite-->
<unattend xmlns="urn:schemas-microsoft-com:unattend">
  <settings pass="windowsPE">
    <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <SetupUILanguage>
        <UILanguage>en-US</UILanguage>
      </SetupUILanguage>
      <InputLocale>0409:00000409</InputLocale>
      <UserLocale>en-GB</UserLocale>
      <UILanguage>en-US</UILanguage>
      <SystemLocale>en-US</SystemLocale>
    </component>
    <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
        <!-- Lifted from Document http://msdn.microsoft.com/en-us/windows/hardware/gg463140.aspx -->
        <DiskConfiguration>
          <Disk wcm:action="add">
            <DiskID>1</DiskID> 
            <WillWipeDisk>true</WillWipeDisk> 
            <CreatePartitions>

              <!-- System partition (ESP) -->
              <CreatePartition wcm:action="add">
                <Order>1</Order> 
                <Type>EFI</Type> 
                <Size>260</Size> 
                <!-- Note: for Advanced Format Generation One drives, change to size=260 -->
              </CreatePartition>

              <!-- Microsoft reserved partition (MSR) -->
              <CreatePartition wcm:action="add">
                <Order>2</Order> 
                <Type>MSR</Type> 
                <Size>128</Size> 
              </CreatePartition>

              <!-- Windows partition -->
              <CreatePartition wcm:action="add">
                <Order>3</Order> 
                <Type>Primary</Type> 
                <Extend>true</Extend> 
              </CreatePartition>
            </CreatePartitions>

            <ModifyPartitions>

              <!-- System partition (ESP) -->
              <ModifyPartition wcm:action="add">
                <Order>1</Order> 
                <PartitionID>1</PartitionID> 
                <Label>System</Label> 
                <Format>FAT32</Format> 
              </ModifyPartition>

              <!-- The MSR partition does not need to be modified -->

              <!-- Windows partition -->
              <ModifyPartition wcm:action="add">
                <Order>2</Order> 
                <PartitionID>3</PartitionID> 
                <Label>Windows</Label> 
                <Letter>C</Letter> 
                <Format>NTFS</Format> 
              </ModifyPartition>
            </ModifyPartitions>
          </Disk>
          <WillShowUI>OnError</WillShowUI> 
        </DiskConfiguration>
      <ImageInstall>
        <OSImage>
          <InstallFrom>
            <MetaData wcm:action="add">
              <Key>/IMAGE/NAME</Key>
              <value>Windows 7 ENTERPRISE</value>
            </MetaData>
          </InstallFrom>
           <InstallTo>
            <DiskID>1</DiskID>
            <PartitionID>3</PartitionID>
          </InstallTo>
          <InstallToAvailablePartition>false</InstallToAvailablePartition>
          <WillShowUI>OnError</WillShowUI>
        </OSImage>
      </ImageInstall>
      <UserData>
        <ProductKey>
          <Key>Some-Funky-Key</Key>
          <WillShowUI>OnError</WillShowUI>
        </ProductKey>
        <Organization>MyCompany</Organization>
        <FullName>Cowboy</FullName>
        <AcceptEula>true</AcceptEula>
      </UserData>
    </component>
  </settings>
  <settings pass="oobeSystem">
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
        <UserAccounts>
            <LocalAccounts>
                <LocalAccount wcm:action="add">
                    <Name>Cowboy</Name>
                    <Group>Administrators</Group>
                    <Password>
                        <PlainText>true</PlainText>
                        <Value>Indian</Value>
                    </Password>
                </LocalAccount>
            </LocalAccounts>
        </UserAccounts>
        <OOBE>
            <NetworkLocation>Work</NetworkLocation>
            <HideEULAPage>true</HideEULAPage>
            <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
        </OOBE>
        <DisableAutoDaylightTimeSet>false</DisableAutoDaylightTimeSet>
        <TimeZone>GMT Standard Time</TimeZone>
        <AutoLogon>
            <Password>
                <Value>Indian</Value>
                <PlainText>true</PlainText>
            </Password>
            <Domain>.</Domain>
            <Enabled>true</Enabled>
            <LogonCount>1</LogonCount>
            <Username>bromine</Username>
        </AutoLogon>
    </component>
  </settings>
  <settings pass="specialize">
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <ComputerName>RENAME_ME</ComputerName>
    </component>
    <component name="Microsoft-Windows-Security-Licensing-SLC-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <SkipAutoActivation>true</SkipAutoActivation>
    </component>
  </settings>
</unattend>

As I said it's pretty much lifted from the TechNet webpage listed above. Any help would be greatly appreciated.

Should this be on SuperUser?

share|improve this question
    
Are you using a 64 bit version of Windows 7? 32 bit versions would not be able to boot from a GPT drive. This information (and more) can be found in the Windows and GPT FAQ. –  WinOutreach4 Aug 17 '12 at 15:16
    
Sorry, missed this comment. I'm using 64bit windows. Will checkout the link. Thanks –  Satpal Aug 21 '12 at 9:19

1 Answer 1

Windows 7 needs an 100mb partition for the Bitlock feature, this is not optional. I do not know how this exactly translates to your setup but probably:

  • partition 1 UEFI
  • partition 2 NTFS 100mb
  • partition 3 NTFS

Good luck

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.