Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I get this message on my bootup screen:

mount: mounting udev on /dev failed: No such device
W: devtmpfs not available, falling back to tmpfs for dev

How do I get rid of it and what does it mean?

I can change to another virtual terminal (tty3 itd.) and login normally.

As far as I can tell the system is functioning normally otherwise after I login. My fstab file has lines for /dev/sda1, /dev/sda2, /dev/cdrom and /

I just upgraded to ubuntu 12.04, I'm running kernel 2.6.28-15-genric.

My system is probably messed up because I followed a non-traditional upgrade path.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

From gentoo-wiki:

devtmpfs: This is a recent addition to the Linux kernel, designed to offer device nodes early at bootup. To use it, enable CONFIG_DEVTMPFS in your kernel .config.

If your kernel has this option enabled, you should have a similar output:

petrus@hive:/boot$ grep CONFIG_DEVTMPFS config-`uname -r`
CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y

However, the message you have at bootup seem to indicate that your kernel hasn't this option , and thus falling back to tmpfs to mount /dev.

You can check which one you are using in /etc/mtab:

petrus@hive:~$ grep /dev /etc/mtab
udev /dev devtmpfs rw,mode=0755 0 0

If you want to mount/remount /dev with devtmpfs:

root@hive:~# mount -t devtmpfs none /dev

However, I don't know where is the system configuration regarding the choice of devtmpfs vs. tmpfs, but using tmpfs should cause no issue.

share|improve this answer
    
Thank you, there indeed was no issue related to this, upgrading the kernel to 3.5 got rid of the message –  tjb Aug 17 '12 at 7:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.