Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I ran dpkg -l tomcat 7 | grep webapp to find the directory where to place my WAR file.

When I dumped my ROOT.war to this directory, the corresponding ROOT directory was populated (exploded is the term, I think).

Then, I restarted (stop, then start) tomcat.

However, I navigated to localhost on port 8080, but I had the same default Apache homepage.

Please advise.

share|improve this question
    
Do you mean you want to make your web application be the Tomcat default app? –  quanta Aug 16 '12 at 15:18
    
I just want to know how to view my webapp from Firefox. localhost on port 8080 doesn't work. I tried localhost/ROOT on port 8080 too, but that failed. –  Kevin Meredith Aug 16 '12 at 15:23
    
wiki.apache.org/tomcat/… –  quanta Aug 16 '12 at 15:36
    
Did you remove the existing directory called "ROOT" before dumping ROOT.war ? –  David Levesque Aug 16 '12 at 17:46
    
Yes, I removed the existing ROOT directory. –  Kevin Meredith Aug 17 '12 at 13:03
add comment

1 Answer

up vote 1 down vote accepted

Generally, absent any other configuration, it would be http://localhost:8080/NAMEOFYOURWEBAPP

share|improve this answer
    
I browsed to localhost:8080 with my ROOT.war, and was able to view my Tomcat-hosted webapp. Yesterday I might've failed to run memcached. Since my app depends on it, then maybe that's why it did not start in Tomcat. –  Kevin Meredith Aug 17 '12 at 13:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.