Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using a MultiTech GPRS modem on Ubuntu 8.0.4 (2.6.24-24 kernel with the MultiTech patches to the ti_usb_3410_5052 module).

The device works great. However if I disconnect it and then reconnect without removing the module in between, it hangs. Attempting to modprobe -r ti_usb_3410_5052 at this point hangs. And running lsusb hangs.

So. There must be a way to trigger the removal of the module when I disconnect the device. Any hints? Maybe a udev rule?

share|improve this question
up vote 1 down vote accepted
  • Have you already tried just using rmmod to remove the module?
  • Also, you should probably put the ppp device down before removing the hardware.
  • If you want to create a udev rule that reacts on removing the driver, something like DRIVER="ti_usb_4410_5052", ACTION="remove", PROGRAM="/sbin/rmmod ti_usb_3410_5052.
share|improve this answer
Yes, everything works properly if I rmmod the module after unplugging the device. The issue is one of automating... There is no ppp device; I'm using the device as an SMS gateway. I don't understand what would trigger that udev rule. It almost looks like it's triggered by unloading the module, which doesn't seem to make sense. What I'd like to see is a udev rule triggered by unplugging the USB device... – Insyte Jul 17 '09 at 10:03
It seems that way; I haven't tried it yet, though. But other people have successfully used similar lines to be triggered when removing USB hardware, cf. – towo Jul 17 '09 at 14:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.