Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When ever i look at ipconfig /all i see that my computers are getting ::1 for the first DNS server from my dhcp server. I have removed this entry from the list of DNS server in the options, but the computer continue to try and use ::1 for the first DNS server.

Is this normal for windows 7?

I am running Windows 2008 r2 server with active directory.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

How long ago did you remove it? A computer will only update its DHCP reservation:

  1. Half-way through its lease. So a 7 day lease will be refreshed after 3.5 days
  2. On reset of the network stack (such as a reboot)
  3. If a new connection is detected (unplug network cable, change WiFi SSID)
  4. A manual ipconfig /renew (or equivalent GUI operation)

If neither of these things have happened, then the computers will still have their old config from the previous DHCP request.

(on a small note, are you 100% sure that it's DHCP being used, and not IPv6 Router Announcements?)

share|improve this answer
    
He could also release and renew, right? –  JohnThePro Aug 16 '12 at 20:34
1  
@JohnThePro - I was just about to update my answer with that ;) –  Mark Henderson Aug 16 '12 at 20:36
    
I have released and renew, rebooted. The Router does not support IPV6 we are just running it basically peer to peer since it came turned on automatically in windows 2008 and 7. Actually i just looked at a different computer i rebooted and it is working now. No ::1 I am not sure how it got in my config in the first place. –  Travis Aug 16 '12 at 21:14
    
@Travis - chances are it came through a Router Advertisement from somewhere, maybe you had another device on the network pretending to be a router or something? You can turn on any recent Windows machine to start broadcasting RA's... –  Mark Henderson Aug 16 '12 at 21:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.