Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have VMWare workstation 8 installed on a windows 7 machine. I have RedHat Enterprise Linux (RHEL) 6 running as a guest OS under VMWare. I am trying to get my web browser from windows 7 host to connect with my guest RHEL web server? I've disabled windows firewall.

VMware's Network settings options are as follows: Bridged, NAT, Host Only, or Custom.

The IP address of the guest OS varies depending on the network option I choose; When I type the variable IP address into the browser of my guest OS, it resolves to the default Apache page. However, when I try this in my host's browser I cannot connect to the server.

I am not using a physical Ethernet connection. I am connected wirelessly to the internet using WiFi network adapter. However, I should be able to connect to the guest OS server without the use of the internet correct? I believe I should be able to use the virtual network adapter to route to the virtual guest server all inside of my machine locally.

i ran ipconfig in windows command prompt which gave the below results:

** note that i am using bridged settings in vmware currently.**

Windows IP Configuration

Wireless LAN adapter Wireless Network Connection 3:

Connection-specific DNS Suffix . : gateway.2wire.net Link-local IPv6 Address . . . . . : fe80::58f3:b55f:b8d9:ed7e%16 IPv4 Address. . . . . . . . . . . : 192.168.1.71 Subnet Mask . . . . . . . . . . . : 255.255.255.0 Default Gateway . . . . . . . . . : 192.168.1.254

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . : memphis.edu

Ethernet adapter VMware Network Adapter VMnet1:

Connection-specific DNS Suffix . : Link-local IPv6 Address . . . . . : fe80::5899:5315:29c1:3772%24 IPv4 Address. . . . . . . . . . . : 192.168.91.1 Subnet Mask . . . . . . . . . . . : 255.255.255.0 Default Gateway . . . . . . . . . :

Ethernet adapter VMware Network Adapter VMnet8:

Connection-specific DNS Suffix . : Link-local IPv6 Address . . . . . : fe80::5031:ad1d:7cb0:4161%25 IPv4 Address. . . . . . . . . . . : 192.168.244.1 Subnet Mask . . . . . . . . . . . : 255.255.255.0 Default Gateway . . . . . . . . . :

Tunnel adapter isatap.{CBB0C40D-6807-4838-A0FC-A6ED59C79F7A}:

Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . :

Tunnel adapter isatap.gateway.2wire.net:

Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . : gateway.2wire.net

Tunnel adapter Local Area Connection* 11:

Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . :

Tunnel adapter isatap.{73368103-5EF9-45EF-89E8-70BD3282EECE}:

Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . :

share|improve this question
    
Unfortunately, "it doesn't work" is not a very good problem description. Can you describe in more detail how exactly you are trying to make it work and what exactly happens? –  David Schwartz Aug 17 '12 at 2:56
    
From the command prompt on your local windows machine, are you able to telnet 192.168.129.129 on port 80? –  Paddington Aug 17 '12 at 6:33
    
If you remember only one thing about virtualisation, remember this: "Nothing Magic happens just because someone said 'Virtual'". You connect your host browser to your guest web server the same way you would any other server and client - there needs to be a valid network route between them. –  RobM Aug 17 '12 at 7:04
    
when i use VMware's bridged setting for my network my vm server ends up with the ip addrss of 192.168.1.71, however this is the same ip address as my lan adapter –  kdavis8 Aug 17 '12 at 22:11

2 Answers 2

up vote 2 down vote accepted

NAT is rarely the best choice for a VM machine and I really can't understand why it's generally the default. Change it to bridged mode (or whatever that's called on VMWare products) and your problems will simply disappear.

share|improve this answer
    
i have switched over to Bridged but yield the same results. However i have noticed that when i run ipconfig inside of windows command prompt, i have two virtual network adapters created by vmware it self. e.g. vmnet8. I am wondering if i should use these "virtual networks" to connect to my guest os –  kdavis8 Aug 17 '12 at 18:20

This is very difficult to answer when we don't know the network settings for your VMWare instance. The basic thing is that you probably want to bridge the guest's NIC with your host NIC (sometimes done with a "TAP" interface, though I'm unaware whether VMWare uses this standard terminology). Then assign an IP address to the guest that is on the same subnet as your host. With both "machines" on the same IP subnet, your browser just uses IP as it would with any remote host.

The fact that you can ping is good. But more diagnostics are required.

If you can't establish socket connections when you think you should, check your host's ARP table and make sure the entry for the guest's IP address is what the guest is answering with. Otherwise, you might have another host on your network that is using the same IP.

Have you confirmed that you can also reach the guest's web browser from a client running on the guest? You can try to establish other socket connections from the host to the guest, using tools like netcat.

share|improve this answer
    
I'm Using NAT to share host IP address. The IP address of the guest RHEL server is 192.168.129.129; when i type this into the browser on my guest it resolves to the default Apache page. However when i try this in my host's browser i cannot connect to the server. –  kdavis8 Aug 17 '12 at 3:19
    
Alrighty. Well, as I said, and as DJ Pon3 said in his comment, make sure the two machines (host and guest) are on the same IP network. Can you ping the guest's IP from the host? You mentioned the guest's IP, but not the host's. Are they in the same subnet? What kind of network interface have you configured in VMWare? TAP/bridged? Go through ALL the diagnostics, not just one or two. –  ghoti Aug 17 '12 at 11:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.