Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have the following settings in my Apache config (not in one of the vhosts but globally):

RailsSpawnMethod smart
RailsAppSpawnerIdleTime 0
PassengerMinInstances 2
PassengerMaxPoolSize 5
PassengerPoolIdleTime 120

but somehow, each time I access my gitlab subdomain, it takes like forever to load once the idle time is exceeded. Same goes for the startup when using PassengerPreStart directive. As I understood the PassengerMinInstances 2 should prevent passenger from closing down completely, so there should be 0 waiting time once passenger was loaded and Apache is not restarting.

share|improve this question
add comment

1 Answer 1

Are you using passenger 3? Because passenger 2 hasn't this option AFAIR. But there is solution for passenger 2

*/5 * * * * curl http://foobar.com

in crontab :)

share|improve this answer
    
I'm using passenger 3 india896:~# passenger --version Phusion Passenger version 3.0.13 –  Martin Müller Aug 22 '12 at 12:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.